• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Bear Bibeault
  • Paul Clapham
  • Jeanne Boyarsky
Sheriffs:
  • Junilu Lacar
  • Knute Snortum
  • Henry Wong
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Frits Walraven
  • Joe Ess
  • salvin francis

Link to a single post

 
Ranch Hand
Posts: 317
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Rancher,

is it possible to refer to a single post? Sometimes that would be useful. I know there is a number attached to each post,
which you can also see in the link (left of "posted Monday bla bla"). But if you click it on it you get only to the top of the thread.
So is is just not working (for me only?) or is it not planned at all.

Thanks
Bob
 
Rancher
Posts: 43011
76
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

I know there is a number attached to each post, which you can also see in the link (left of "posted Monday bla bla"). But if you click it on it you get only to the top of the thread.


This does work fine for me (and, based on the lack of bug reports around this, presumably for others as well). E.g., does https://coderanch.com/t/423549/Product-Other-Certifications/certification/Spring-Certification#2007552 not take you to the last post of that topic?
 
Bob Wheeler
Ranch Hand
Posts: 317
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Ulf Dittmer wrote:

I know there is a number attached to each post, which you can also see in the link (left of "posted Monday bla bla"). But if you click it on it you get only to the top of the thread.


This does work fine for me (and, based on the lack of bug reports around this, presumably for others as well). E.g., does https://coderanch.com/t/423549/Product-Other-Certifications/certification/Spring-Certification#2007552 not take you to the last post of that topic?


No. Doesn't work; tested on Firefox (3.0) and IE (7.0). All running on WinXP Prof.
Not my homesystem. I can check it later on Ubuntu.

cheers
Bob
 
Bob Wheeler
Ranch Hand
Posts: 317
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Just for information:
I checked my error console (Firefox) and got some error messages of this and other form:

Security Error: Content at http://googleads.g.doubleclick.net/ may not load data from...


Always http://googleads.g.doubleclick.net/ is part of. If I turn JavaScript off, they are gone.
Maybe that's part of the problem described above. Don't know. Just for information.

cheers
Bob
 
Bartender
Posts: 10336
Hibernate Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Works fine for me in Firefox 3.0.11 running with NoScript turned on and in IE7 (also running on Win XP Professional). It doesn't use script - its using a fragment identifier to do it.

Must be something peculiar about your set up. User agents are supposed to give up trying to resolve fragment identifiers if the user agent has stopped parsing - do you have any plug-ins or extension on your browsers that might cause this?
 
Sheriff
Posts: 6446
1155
IntelliJ IDE jQuery Eclipse IDE Postgres Database Tomcat Server Chrome Google App Engine
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Bob Wheeler wrote:

Ulf Dittmer wrote:

I know there is a number attached to each post, which you can also see in the link (left of "posted Monday bla bla"). But if you click it on it you get only to the top of the thread.


This does work fine for me (and, based on the lack of bug reports around this, presumably for others as well). E.g., does https://coderanch.com/t/423549/Product-Other-Certifications/certification/Spring-Certification#2007552 not take you to the last post of that topic?


No. Doesn't work;



It doesn't work for me too. I found that there are no label given for the id "2007552" in that page, so it may be the problem. But there IS a label given for "post_text_2007552", so the following URL works fine for me:

https://coderanch.com/t/423549/Product-Other-Certifications/certification/Spring-Certification#post_text_2007552

I think that the cell id format which containing the message should be changed. For this example "post_text_2007552" should be changed for "2007552".
 
Paul Sturrock
Bartender
Posts: 10336
Hibernate Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The source already contains a div element with the id 2007552.
 
Devaka Cooray
Sheriff
Posts: 6446
1155
IntelliJ IDE jQuery Eclipse IDE Postgres Database Tomcat Server Chrome Google App Engine
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Paul Sturrock wrote:The source already contains a div element with the id 2007552.



Mmmm, is this the thing you are talking about?

It is not supposed to do that.
 
Ulf Dittmer
Rancher
Posts: 43011
76
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No, Paul is talking about <div class="edit_area" id="2007552">.

What should really be there is something like <a name="2007552">. I never knew that the hash notation worked for IDs at all.
 
Paul Sturrock
Bartender
Posts: 10336
Hibernate Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No. I'm talking about the div tag with the id specified above:

Which is a child of the element you mention in your first post.
 
Paul Sturrock
Bartender
Posts: 10336
Hibernate Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Ulf Dittmer wrote:No, Paul is talking about <div class="edit_area" id="2007552">.

What should really be there is something like <a name="2007552">. I never knew that the hash notation worked for IDs at all.



It's HTML 5, so newish (only found that out myself a few months ago ).
 
Devaka Cooray
Sheriff
Posts: 6446
1155
IntelliJ IDE jQuery Eclipse IDE Postgres Database Tomcat Server Chrome Google App Engine
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Paul Sturrock wrote:The source already contains a div element with the id 2007552.


I couldn't see any div tag with id element in the source. I think that the JSP renders that div tag only for those who have bartender or higher privileges, that is why it works fine for you and Ulf.
 
Paul Sturrock
Bartender
Posts: 10336
Hibernate Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You may be onto something. I get the same behaviour when I log out then click the link. Looks like a little bug after all.
 
Devaka Cooray
Sheriff
Posts: 6446
1155
IntelliJ IDE jQuery Eclipse IDE Postgres Database Tomcat Server Chrome Google App Engine
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Strange! I couldn't find that tag, even after logging out.
 
Paul Sturrock
Bartender
Posts: 10336
Hibernate Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
...I mean the same behaviour as you are seeing.
 
Devaka Cooray
Sheriff
Posts: 6446
1155
IntelliJ IDE jQuery Eclipse IDE Postgres Database Tomcat Server Chrome Google App Engine
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
A privileged bug
 
Ulf Dittmer
Rancher
Posts: 43011
76
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
OK, we're going to have proper <a name="..."> tags for all visitors in the next release of the forum software; that should presumably work in all browsers.
 
Bob Wheeler
Ranch Hand
Posts: 317
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Ulf Dittmer wrote:OK, we're going to have proper <a name="..."> tags for all visitors in the next release of the forum software; that should presumably work in all browsers.


Would be enough to give me bartender privileges.

cheers and thanks
Bob
 
Marshal
Posts: 66949
255
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Bob Wheeler wrote:Would be enough to give me bartender privileges.

You mean bartender responsibilities?
 
Rancher
Posts: 3410
34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
How about free beer, at least?
 
Ulf Dittmer
Rancher
Posts: 43011
76
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This should now work for everybody.
 
Rancher
Posts: 425
Android Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Ulf Dittmer wrote:This should now work for everybody.



Yes. It is now working fine in my system. Checked with Firefox 3.5.

Thanks Ulf.


-Pushkar
 
Bob Wheeler
Ranch Hand
Posts: 317
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Ulf Dittmer wrote:This should now work for everybody.


Thanks a lot. It's working like a new oiled machine.

cheers
Bob
 
author
Posts: 15385
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There fancy quotes and code blocks on the page that changes sizes and causes the location of the link to be off.

We might need some JS magic in there.

Eric
 
I'm THIS CLOSE to ruling the world! Right after reading this tiny ad:
Sauce Labs - World's Largest Continuous Testing Cloud for Websites and Mobile Apps
https://coderanch.com/t/722574/Sauce-Labs-World-Largest-Continuous
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!