Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

[Microsoft][SQLServer 2000 Driver for JDBC]Unsupported VM encoding Cp1256.

 
Sherif Shehab
Ranch Hand
Posts: 487
Android Eclipse IDE Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Guys ,

My reporting system (developed by servelts , jsp and apache POI ) was working fine , until this exception occurss


i searched on the net about any solution for this exception but all saying that there is someting wrong in the sql jdbc driver !!! without providing any guide lines, actually i;m not convinced with this beacus my application was working fine for more than 3 weeks now plus i didnt make any changes !!!

I;m guessing some thing that some thing was changed in the Db that i;m generating my reports from ...

Ps : didn't changed anything related to the encoding !!

How i can solve this exception
 
Deepak Bala
Bartender
Posts: 6663
5
Firefox Browser Linux MyEclipse IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Perhaps your report now has some data that cannot be represented by a particular encoding?

Run a query that generates reports on old data. If that works then you can differentiate if the problem is with the base encoding of the DB, or the encoding of the data or something to do with the driver (which I do not think is likely. Never seen anything like that before.)
 
Sherif Shehab
Ranch Hand
Posts: 487
Android Eclipse IDE Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
by the way i found a wrerid thig when i deploy the WAR (myapplication ) on the testing server and run it it works fine , but when i take the same WAR then try to run it on the production server this error occurs !!!

i dont know what this exception about !! but i think it;s some thing not related to my code , am i right ??
 
Sherif Shehab
Ranch Hand
Posts: 487
Android Eclipse IDE Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Guys i solved this problem , simply install arabic language on the machine that got the production server , it's working fine now
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic