Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

installing maven 2

 
sam liya
Ranch Hand
Posts: 1240
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
when i am going to install maven 2 plugin it gives this error." Maven Integration for AJDT (Optional) (0.9.8.200905041414) requires feature "org.eclipse.ajdt (1.5.0)", or later version."

here is the site which i am going to install maven 2.
"http://m2eclipse.sonatype.org/update/"
can anyone tell me what is the error?
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That usually means that the version of the plugin you're installing requires a later version of another component--you should either upgrade your Eclipse, or downgrade the plugin. This should probably be in the IDE forum since it's an issue with the IDE/plugin, not specifically Maven.
 
sam liya
Ranch Hand
Posts: 1240
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
now it gives this error.
Maven issue tracking configurator for Mylyn 3.x (Optional) (0.9.6.20080905-0917) requires plug-in "org.eclipse.mylyn.tasks.ui (3.0.0)", or compatible.
can anyone tell me which pluging shuld i install?
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The one it told you to.

Don't just randomly check boxes in a dialog: if you're not going to use issue tracking integration don't install it, and if you are, install its dependencies.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic