Win a copy of Practical SVG this week in the HTML/CSS/JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Problem with look up JNDI on JBOSS

 
avseq anthoy
Ranch Hand
Posts: 106
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear all
I configure JNDI setting on JBoss , but it can't work.
Are there any wroing with my config?

My environment:
JBOSS 5.1.0 GA , JDK1.5.0_10-b03

My Step to Configure JNDI
Step 1:
Copy oracle-ds.xml from $JOBSS\docs\examples\jca to $JOBSS\server\default\deploy.
And change the content as follow


Step 2:
modify WEB-INF/web.xml
add the following content


Step 3:
Add jboss-web.xml in WEB-INF folder.
The content as below


Step 4:
My Spring config as below


But it still has error message , the message as below


Are there any wrongs with my steps?
Or I should modify some config file?
Please someone help me to solve the proble,the problem perplex me too long.
tks!
 
Jaikiran Pai
Sheriff
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator


This doesn't looks right. I don't know much about Spring, but i guess you should specify the resource-ref name here. So:


 
avseq anthoy
Ranch Hand
Posts: 106
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
tks for your reply!
I modify the config according your post.
The error message is different with before,the error message as below


hibernate-config.xml as below

Are there any wrongs with my config?
tks~
 
I'm a lumberjack and I'm okay, I sleep all night and work all day. Lumberjack ad:
the new thread boost feature: great for the advertiser and smooth for the coderanch user
https://coderanch.com/t/674455/Thread-Boost-feature
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!