Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Failed to deploy servlet in netbeans 6.7

 
Naveen Akshaye
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I'm using Netbeans 6.7 to write servlets and depoly to Tomcat server 5.5, but everytime the deployment failed. It always outputs the following error message:


The servlet file is a very simple one, and the build of the project is successful to generate the WAR. The tomcat server works well if I manually copy the .war file into the "webapps" folder. The catalina base and appBase is set to one folder under my $HOME directory, so that I have the privilege to write. However, the Netbeans always failed to deploy it into server. I have specified correct locations for $CATALINA_HOME and $CATALINA_BASE in server configuration. I also tried the default system configuration, got the same error msg.

Anyone has idea about this?

Thanks,
Naveen.
 
olze oli
Ranch Hand
Posts: 149
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
same problem here... no one who can help? :/
 
Seetharaman Venkatasamy
Ranch Hand
Posts: 5575
Eclipse IDE Java Windows XP
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
[i am not sure] clean and re-build
 
olze oli
Ranch Hand
Posts: 149
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
doesnt help anything... just trying to install tomcat and liferay by hand, because i used the bundle.. maybe this is the problem.. dont know :/
 
Ankit Garg
Sheriff
Posts: 9527
32
Android Google Web Toolkit Hibernate IntelliJ IDE Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Naveen the output window in Netbeans also shows the output of the Tomcat console. That will contain the actual cause of the problem. Can you please post that...
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 65111
89
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Moved to the IDEs forum.
 
olze oli
Ranch Hand
Posts: 149
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i've made it myself with tomcat 6.0.20 and its working
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic