Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Want to run Java Applet compactable with Java 1.5 in browser having JRE- plugin 1.4

 
Tarunam Verma
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Application has migrated from java 1.4 to java 1.5, but the IE on which the Application Applet is running is still jre-plugin 1.4.Cant upgrade the JRE-plugin from 1.4 to 1.5 for the IE.So need a solution on code level, i was trying to do with object tag by CLSID in JSP but that seems to be no success as it is a vice versa case.

Thanks,
Tarunam
 
Peter Johnson
author
Bartender
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Does the application use 1.5-specific features? If so, then what you want to do is not possibly. If the app does not use 1.5 features, you're simply compiling with a 1.5 compiler, you can set -source and -target of javac to 1.4.
 
Ulf Dittmer
Rancher
Posts: 42969
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
A tool like Retroweaver can transform code that uses Java 5 features into code that's compatible with Java 1.4. That only works for Java 5 syntax, though, not for new methods or classes.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic