Only 48 hours left in the trailboss' kickstarter!

New rewards and stretch goals. CLICK HERE!



  • Post Reply Bookmark Topic Watch Topic
  • New Topic

StackOverflowException in Weblogic server  RSS feed

 
Ravi Kiran Va
Ranch Hand
Posts: 2234
Eclipse IDE Firefox Browser Redhat
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello ,

I am getting a StackOverflowException and i am using Weblogic server , please tell me how can i solve this ?


Please help what steps i need to do ?
 
Marcos Maia
Ranch Hand
Posts: 977
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

this is because you have some routine in code which uses more than default allocated memory for a thread. Are you using JRockit? To solve this you will need to set a JVM parameter to increase default thread stack size:

-Xss

http://download.oracle.com/docs/cd/E13150_01/jrockit_jvm/jrockit/jrdocs/refman/optionX.html#wp999540

[]s
 
Ravi Kiran Va
Ranch Hand
Posts: 2234
Eclipse IDE Firefox Browser Redhat
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Marcos ,

Do i need to set this value (Xss ) in weblogic startup bat file ??
 
Marcos Maia
Ranch Hand
Posts: 977
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

if you want to ajust this only to admin server you can edit the startWeblogic script. For managed servers startManagedWeblogic and if you are using node manager select server > server start and put in jvm arguments.
You will find information about variables like JAVA_OPTIONS you may set on the scripts if you want to edit them.

[]s
 
Ravi Kiran Va
Ranch Hand
Posts: 2234
Eclipse IDE Firefox Browser Redhat
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you very much
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!