• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

http 500 internal server error

 
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello All,

I am getting http 500 internal server error error when I am calling an action class from a jsp page.
I am using jdeveloper 11g and struts version 1.2.
When I am trying to access the ActionClass the "http 500 internal server error" is being shown and I am not getting any error messages or exceptions on any log files. I even tried the Weblogic console as well, but could not found any exception pertaining to this problem.
Surprisingly on the same page other <html:link> works properly.

Following is the struts-config.xml entry,

Following is the jsp snippet,


web.xml entry is as follows,


I am getting following warning messages during, server startup



Can anyone please tell me what i need to do?

Regards,
Joydeep
 
Author
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Anything in the logs when you actually get the error?
 
joydeep sarkar
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
No, I don't see any error messages in any log file. I even checked the webapplication-oc4j-app.log and application.log file, but still no error messages.

One thing that I noticed that first line of the ActionClass is a print statement, which is not getting printed. But all the SOPs are there until the control reaches the ActionClass.
 
David Newton
Author
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I'd try increasing the logging levels first or scouring the logs more.
 
joydeep sarkar
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I managed to solve the problem.
Actually the ActionForm has a validate method, which returns ActionErrors. As there were no errors, the method returned empty ActionErrors instance. And the struts config did not have any input page for the validation.

Two ways to get rid of this scenario, either to make validation="false" or to remove the validate() methond from the form bean.

Would like to know the reason though. Thanks for the support.

Regards,
Joydeep
 
They gave me pumpkin ice cream. It was not pumpkin pie ice cream. Wiping my tongue on this tiny ad:
a bit of art, as a gift, that will fit in a stocking
https://gardener-gift.com
reply
    Bookmark Topic Watch Topic
  • New Topic