Help coderanch get a
new server
by contributing to the fundraiser
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Is it not possible to install apache-tomcat-6.0.20 as a service in WindowsXP SP3?

 
Ranch Hand
Posts: 213
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
When I run the set up apache-tomcat-6.0.20.exe for WindowsXP I get the message from the Tomcat Setup as "Failed to install tomcat6 service check your settings and permissions".I have the permissions.The only thing I think that is different from the setup needs is the JRE version.But the tomcat-preconfigured-6.0.18.zip downloaded from coreservlets.com works fine with the J2SE 6 JRE.The setup always stops when the setup dialog box displays the message "using jvm:c:\program files\java\jre\bin\client\jvm.dll".There is no any other service or another version of Tomcat installed even as a service.


I installed Tomcat using apache-tomcat-6.0.20.exe But not as a service.Then from the bin I tried to run "tomcat6.exe service runner" But it did not start the service log is as follows

[2009-07-21 20:02:34] [info] Procrun (2.0.4.0) started
[2009-07-21 20:02:34] [info] Service Tomcat6 name Apache Tomcat 6
[2009-07-21 20:02:35] [info] Service Tomcat6 installed
[2009-07-21 20:02:35] [info] Procrun finished.
[2009-07-21 21:46:10] [info] Procrun (2.0.4.0) started
[2009-07-21 21:46:10] [info] Debugging Service...
[2009-07-21 21:46:10] [info] Starting service...
[2009-07-21 21:46:10] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:46:10] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:46:10] [info] Debug service finished.
[2009-07-21 21:46:10] [info] Procrun finished.
[2009-07-21 21:46:14] [info] Procrun (2.0.4.0) started
[2009-07-21 21:46:14] [info] Debugging Service...
[2009-07-21 21:46:14] [info] Starting service...
[2009-07-21 21:46:14] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:46:14] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:46:14] [info] Debug service finished.
[2009-07-21 21:46:14] [info] Procrun finished.
[2009-07-21 21:46:24] [info] Procrun (2.0.4.0) started
[2009-07-21 21:46:24] [info] Running Service...
[2009-07-21 21:46:24] [info] Starting service...
[2009-07-21 21:46:24] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:46:24] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:46:24] [info] Run service finished.
[2009-07-21 21:46:24] [info] Procrun finished.
[2009-07-21 21:46:28] [info] Procrun (2.0.4.0) started
[2009-07-21 21:46:28] [info] Running Service...
[2009-07-21 21:46:28] [info] Starting service...
[2009-07-21 21:46:28] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:46:28] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:46:28] [info] Run service finished.
[2009-07-21 21:46:28] [info] Procrun finished.
[2009-07-21 21:46:31] [info] Procrun (2.0.4.0) started
[2009-07-21 21:46:31] [info] Running Service...
[2009-07-21 21:46:31] [info] Starting service...
[2009-07-21 21:46:32] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:46:32] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:46:32] [info] Run service finished.
[2009-07-21 21:46:32] [info] Procrun finished.
[2009-07-21 21:46:35] [info] Procrun (2.0.4.0) started
[2009-07-21 21:46:35] [info] Running Service...
[2009-07-21 21:46:35] [info] Starting service...
[2009-07-21 21:46:35] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:46:35] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:46:35] [info] Run service finished.
[2009-07-21 21:46:35] [info] Procrun finished.
[2009-07-21 21:53:44] [info] Procrun (2.0.4.0) started
[2009-07-21 21:53:44] [info] Debugging Service...
[2009-07-21 21:53:44] [info] Starting service...
[2009-07-21 21:53:44] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:53:44] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:53:44] [info] Debug service finished.
[2009-07-21 21:53:44] [info] Procrun finished.
[2009-07-21 21:54:06] [info] Procrun (2.0.4.0) started
[2009-07-21 21:54:06] [info] Debugging Service...
[2009-07-21 21:54:06] [info] Starting service...
[2009-07-21 21:54:06] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:54:06] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:54:06] [info] Debug service finished.
[2009-07-21 21:54:06] [info] Procrun finished.
[2009-07-21 21:55:44] [info] Procrun (2.0.4.0) started
[2009-07-21 21:55:44] [info] Debugging Service...
[2009-07-21 21:55:44] [info] Starting service...
[2009-07-21 21:55:44] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:55:44] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:55:44] [info] Debug service finished.
[2009-07-21 21:55:44] [info] Procrun finished.
[2009-07-21 21:55:44] [info] Procrun (2.0.4.0) started
[2009-07-21 21:55:44] [info] Debugging Service...
[2009-07-21 21:55:44] [info] Starting service...
[2009-07-21 21:55:44] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:55:44] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:55:44] [info] Debug service finished.
[2009-07-21 21:55:44] [info] Procrun finished.
[2009-07-21 21:55:45] [info] Procrun (2.0.4.0) started
[2009-07-21 21:55:45] [info] Debugging Service...
[2009-07-21 21:55:45] [info] Starting service...
[2009-07-21 21:55:45] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:55:45] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:55:45] [info] Debug service finished.
[2009-07-21 21:55:45] [info] Procrun finished.



Your ideas please!!!
 
Bartender
Posts: 4116
72
Mac TypeScript Chrome Java Linux
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
CrossPosted
 
Ranch Hand
Posts: 470
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Varuna Seneviratna wrote:The setup always stops when the setup dialog box displays the message "using jvm:c:\program files\java\jre\bin\client\jvm.dll"



Any other messages during set up? Are you sure that you are using administrative account? Do you have any anti-virus software running on you machine?
 
Ever since I found this suit I've felt strange new needs. And a tiny ad:
We need your help - Coderanch server fundraiser
https://coderanch.com/t/782867/Coderanch-server-fundraiser
reply
    Bookmark Topic Watch Topic
  • New Topic