Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JVM Hot Spot issue (in 1.6)

 
Karthick Dharani Vidhya
Ranch Hand
Posts: 91
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

If i run my java application using 1.5, it works fine.
The same application if I run using 1.6.0_13, after some time the java application closes by genarting the below mentioned file in my desktop.





What I see is, in LineNo.155 the PermSize is used 99%.
I have not specified any PermSize. Can some one tell me, what will be the default PremSize?
If someone has already faced it, could you please suggest some solutions.
 
Karthick Dharani Vidhya
Ranch Hand
Posts: 91
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

Sorry for the late reply.

The day I posted the above question, I came to know that this happens when both JVM code and native code tries to access same native resource. See below.

NATIVE
---------

Stack: [0x02fa0000,0x02ff0000], sp=0x02fef2a4, free space=316k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [awt.dll+0x3920c]

JVM
----

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j sun.awt.windows.WToolkit.eventLoop()V+0
j sun.awt.windows.WToolkit.run()V+69
j java.lang.Thread.run()V+11
v ~StubRoutines::call_stub

This happens many time in 1.6, as Sun has enhanced the use of D3D feature. To avoid this error, I was suggested to set the below parameter to FALSE. (If your application is not using any high level 3D rendering)

-Dsun.java2d.d3d=false.

After setting this, it looks ok.
 
tom wangrui
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i think your Perm Space that you allocated in JVM is not large enough
 
Karthick Dharani Vidhya
Ranch Hand
Posts: 91
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Thanks for the reply.

At first, even I thought it could be Perm Size issue. But after finding the above solution in SUN's site, i just set that property to false. I did not change the Perm size of the application, but with this property it looks OK till today.
 
tom wangrui
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
OK,that's perfect
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic