Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
    Bookmark Topic Watch Topic
  • New Topic

jboss started.. but localhost:8080 throwing an error

 
Srikanthh Ar
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Report post to moderator
i used eclipse and coded a servlet.

i used jboss to debug. while debugging i got this exception

09:42:30,734 ERROR [Http11Protocol] Error starting endpoint
java.net.BindException: Address already in use: JVM_Bind:8080

and at last i got

09:42:30,734 INFO [Server] JBoss (MX MicroKernel) [4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181439)] Started in 30s:125ms

in my console...

then i deployed my war file..

09:43:00,718 INFO [TomcatDeployer] deploy, ctxPath=/one, warUrl=.../tmp/deploy/tmp7742847336317735345one-exp.war/
09:43:00,812 INFO [JBossCacheManager] Starting JBossManager

came in my eclipse console....

when i opened the browser and typed http://localhost:8080

i got a page not found error....

whether my jboss started or not.. my eclipse console showing jboss started... but http://localhost:8080 is not working.. throwing an error.. why is it so...

what's the problem...
 
Jaikiran Pai
Marshal
Pie
Posts: 10447
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Report post to moderator
java.net.BindException: Address already in use: JVM_Bind:8080


That means an error. See this for details http://www.jboss.org/community/wiki/DebugBindException
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Report post to moderator
Srikanthh, please do not ask the same question in multiple forums (your other post which started in the servlets forum and went to the IDE forum also ended up here.). Now I have to decide which one to lock. I'll lock this one. Discussion continued at http://www.coderanch.com/t/455329/JBoss/http-localhost-not-opening
 
    Bookmark Topic Watch Topic
  • New Topic