Win a copy of Fixing your Scrum this week in the Agile forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Rob Spoor
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Junilu Lacar
  • Tim Cooke
Saloon Keepers:
  • Tim Holloway
  • Piet Souris
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
Bartenders:
  • Frits Walraven
  • Himai Minh

In jboss ClassNotFoundException: No ClassLoaders found for: org.richfaces.function.RichFunction

 
Ranch Hand
Posts: 88
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I started jboss 4.3.0.GA_CP03 and run it successfully but when I tried to login I got the following errors:

1) java.lang.ClassNotFoundException: No ClassLoaders found for: org.richfaces.function.RichFunction
But I have include these library to my WEB-INF/lib/
commons-collections-3.2.1.jar
commons-digester-1.8.jar
commons-logging-1.1.1.jar
laguna-3.2.2.GA.jar
richfaces-api-3.2.2.SR1.jar
richfaces-impl-3.2.2.SR1.jar
richfaces-ui-3.2.2.SR1.jar

2) java.lang.ClassNotFoundException: No ClassLoaders found for: com.zzzz.pppp.web.util.ELUtility
But the class is exists in the same path in my war file as WEB-INF/classes/com.zzzz.pppp.web.util.ELUtility
I have used tld functions in this class.

Note that the same war file is working properly in Tomcat, but in JBoss still not working

Please Help..
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Please post the entire exception stacktrace. Also you seem to be using the EAP edition of JBoss which has a support contract. You can get quicker support for your issues from the EAP support portal.
 
Ashraf Abu-Aisheh
Ranch Hand
Posts: 88
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I tried also with jboss-5.1.0.GA version, and got the same exception
Find the following the entire exception stack trace....,


and the following error also


I think the errors regarding the tld's, please help
 
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Did you include the richfaces JAR file in your app? It doesn't come with JBoss AS (well, admin-console uses it, but it packages the richfaces JAR within itself).
 
Ashraf Abu-Aisheh
Ranch Hand
Posts: 88
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Peter Johnson wrote:Did you include the richfaces JAR file in your app? It doesn't come with JBoss AS (well, admin-console uses it, but it packages the richfaces JAR within itself).



I have already included these library to my WEB-INF/lib/

richfaces-api-3.2.2.SR1.jar
richfaces-impl-3.2.2.SR1.jar
richfaces-ui-3.2.2.SR1.jar

Did you mean the above library with "richfaces JAR" or there are other libraries missed.
 
Peter Johnson
author
Posts: 5856
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I don't use RichFaces. I was posting in response to the first error:

java.lang.ClassNotFoundException: No ClassLoaders found for: org.richfaces.function.RichFunction

Does one of the files you listed contain this class?

I always prefer solving the first error first (and ignoring all other errors) because often once the first error is solved many of the others errors go away also. So looking at any error other than the first is usually a waste of time.
 
Ashraf Abu-Aisheh
Ranch Hand
Posts: 88
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Peter Johnson wrote:I don't use RichFaces. I was posting in response to the first error:

java.lang.ClassNotFoundException: No ClassLoaders found for: org.richfaces.function.RichFunction

Does one of the files you listed contain this class?

I always prefer solving the first error first (and ignoring all other errors) because often once the first error is solved many of the others errors go away also. So looking at any error other than the first is usually a waste of time.



I fixed it by copying the following libraries to the jboss-as\server\default\lib directory
richfaces-api-3.2.2.SR1.jar
richfaces-impl-3.2.2.SR1.jar
richfaces-ui-3.2.2.SR1.jar

Thank you Mr.Peter Johnson to reply to my post, your replying is a dignity to me
 
You showed up just in time for the waffles! And this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic