Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

difference between war deploy and eclipse deploy

 
roel croonenberghs
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I have a JSF project and when I test it under eclipse with tomcat-6.0.18 it all works fine. But when I make a war file with ant, deploy it to my tomcat-6.0.18 server manually (using Tomcat Web Application Manager), and then access the same page, I get an error

the code is

wich calls

Any suggestions on why it compiles and runs under eclipse, but not when I build it with ant?

I'm using tomcat-6.0.18 with java jdk 1.6.0
eclipse-3.5
ant-1.6.5

Roel
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34973
379
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
roel croonenberghs wrote:Any suggestions on why it compiles and runs under eclipse, but not when I build it with ant?Roel

Welcome to JavaRanch!

The two most common causes for this error are:
1) You are compiling with Java 1.4 or earlier. (You can have Ant spit out the version of Java it is using to be sure.)
2) You have an old jar lying around with a different signature. (You can check this by looking at the classpath.)
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic