Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Iterating through an array of objects in a jsp

 
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am not able to figure out why this isnt working. I would appreciate if some one can spot the issue with this code -

I have a class DNPrsnDtls
I have an arrayList of DNPrsnDtls as an attribute in the Form associated - SFPrsnDtls.
In the jsp associated, I am trying to loop through the aoDNPrsnDtls and display an attribute specific to DNPrsnDtls.

I am getting an error saying cannot find bean in any scope.

 
Ram Pathan
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
A real sucker. It ate up 3 hours. Time to get back to basics.



... One of the many reasons why you might get that error.

I wish the error was more descriptive.
 
Marshal
Posts: 67451
173
Mac Mac OS X IntelliJ IDE jQuery Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Why are you asking Struts questions in a SCWCD forum?

 
Author
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Somewhat off-topic, but those variable names would drive me /insane/.

DNPrsnDtls... really? Keyboards have vowels for a reason: we're not using SMS devices to code.
 
Greenhorn
Posts: 20
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator


<%@taglib uri="http://jakarta.apache.org/struts/tags-logic"; prefix="logic" %>



I had the same problem, thought I was doing everything right. The above code is what fixed the problem!
    Bookmark Topic Watch Topic
  • New Topic