Jay Stryper wrote:Query on the question
JavaBeans methods must be named in camelCase and depending on the method's purpose must start with set, get, add or remove
This would mean that A is also correct
add and remove are used for listeners and components in AWT and JFC in most cases.....
it is also obvious that you are not going to add size but only set it......... add doesn't make any sensse in this context.....