Win a copy of Penetration Testing Basics this week in the Security forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

[Axis2] SocketPermission exception while calling another webservice in WAS 5.1

Rajeevr Singh
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator


I run Axis 1.3 project on WebSphere Platform 5.1 with JDK 1.4.2. Host Operating System is Linux.

I have two web services. I get SocketPermission error while the first service calls the next service. Both services are placed at the same jvm. I even tried to deploy these two services on two different jvm but I get the same error.

Same works fine in local Tomcat environment. I have proper policy entry for this in was.policy file.

Can it be related to port access rights?

I can see SimpleHTTPServer transportReceiver is set to 8080 in axis2.xml file. Do we need to change it to some other value? I don't have admin access to WAs so cannot comment on this.

Log trace is:
[8/24/09 2:34:47:667 EDT] 6c1dbeed SystemOut O Before calling partnerOutFLow Service
[8/24/09 2:34:47:758 EDT] 6c1dbeed SecurityManag W SECJ0314W: Current Java 2 Security policy reported a potential violation of Java 2 Security Permission. Please refer to Problem Determination Guide for further information.
Permission: : access denied ( resolve)
Code: in {file:/opt/httpd/root/apps/wsx/ibm/ccx-dev-ear/wsx.war/WEB-INF/services/PartnerService/}
Stack Trace: access denied ( resolve)

was.policy file:
grant codeBase "file:${application}"
permission java.lang.RuntimePermission "accessClassInPackage.sun.util.logging.resources";
permission "${was.install.root}/properties", "read";
permission "/opt/netegrity/siteminder/taiagent/TAI-1.0/config/ccxapp-dev-3", "read";
permission "/opt/netegrity/siteminder/taiagent/TAI-1.0/config/ccxapp-stage-4", "read";
permission "/opt/netegrity/siteminder/taiagent/TAI-1.0/config/ccxapp-stage-20", "read";
permission "/opt/netegrity/siteminder/taiagent/TAI-1.0/config", "read";
permission java.lang.RuntimePermission "shutdownHooks";
permission "", "resolve,connect";
permission "", "connect,resolve";

Can someone give pointer to this problem?

Thanks in advance.

  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic