• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Tomcat compatibility with JRE 1.6

 
suresh nuzella
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Can any one explain me whether tomcat 5.0.28 is compatible with JRE 1.6 or I need to install any other version of tomcat?Also what are the general things we need to consider when we are upgrading to JRE 1.6 from 1.4x

Please do the needfull.

 
Vijitha Kumara
Bartender
Posts: 3914
9
Chrome Fedora Hibernate
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tomcat 6.0 designed to run on JSE 5.0 and later. Check the docs for more info.
 
suresh nuzella
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
that means I need to change the version of my tomcat?
 
suresh nuzella
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
please help me on this whether I need to change my tomcat version or the older version(5.0.28) will serve the purpose?
 
Tim Holloway
Saloon Keeper
Pie
Posts: 18277
56
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You can run Tomcat5 with JDK 6. Although there's been talk about a Tomcat that runs under just a JRE, as far as I know, they all still require the full JDK.

This isn't Microsoft where version dependency breakage is an ordinary part of life. Java was expressly designed to support backwards compatibility.

It's not a bad idea to move to Tomcat6, though. There's relatively little trauma in moving from TC5.5 to TC6.
 
suresh nuzella
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks for your reply
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic