Version 1.0 requires JDK 1.4 or higher. The version in SVN trunk and all future releases will require JDK 1.5 or higher.
However, some users have contributed patches to make later versions compatible with JDK 1.4. Please check the contributions/ directory in the source repository for any such patches. Note that any code in this directory is untested and unsupported, so please use at your own risk and do not file bugs based on that code.
You could try downloading the source (available as well), then build it using Java 1.4, but you probably need to change a few lines of code to make it compatible. Alternatively, you could try using Retroweaver.