• Post Reply Bookmark Topic Watch Topic
  • New Topic

import jackcess jar error  RSS feed

 
a mhamad
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dears,

I'm using Oracle Jdeveloper on windows XP, i downloaded latest version from jackcess-1.1.9. and added it to classpath but everytime trying to run the project i got the following error:

Error(3,41): cannot access class com.healthmarketscience.jackcess.Database; class file has wrong version 49.0, should be 45.3 or 46.0 or 47.0 or 48.0

from jackcess librry import line, although i'm running on java 1.4.2

import com.healthmarketscience.jackcess.Database;

I also tried with previous archived version from jackcess-1.1.8

Did i miss something here!!!

Any help is appreciated.
 
Rob Spoor
Sheriff
Posts: 21135
87
Chrome Eclipse IDE Java Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
From the FAQ:
What version of the JDK does this require?

Version 1.0 requires JDK 1.4 or higher. The version in SVN trunk and all future releases will require JDK 1.5 or higher.

However, some users have contributed patches to make later versions compatible with JDK 1.4. Please check the contributions/ directory in the source repository for any such patches. Note that any code in this directory is untested and unsupported, so please use at your own risk and do not file bugs based on that code.

You could try downloading the source (available as well), then build it using Java 1.4, but you probably need to change a few lines of code to make it compatible. Alternatively, you could try using Retroweaver.
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!