Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

struts1.1 doesn't work correctly in weblogic7.0,need some help,thanks

 
Nikko Fu
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
there's an j2ee project,needs struts for web framework and ejb for web logic application.
how can they work together in weblogic7.0.
i modified the startWLS.cmd and added the struts.jar to the classpath,but found the struts didn't work correctly in the weblogic7.0,neither the struts project i developed with jbuilder nor the struts-example in the tomcat/struts-webapps.

Error 500--Internal Server Error
From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:
10.5.1 500 Internal Server Error
The server encountered an unexpected condition which prevented it from fulfilling the request.

do not tell me the suggestion is to use the tomcat to run the struts and the weblogic to run the ejb,because i will cry~~~~~~~~.
5555555555555
some one help me,with many thanks
 
Matthew Phillips
Ranch Hand
Posts: 2676
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Struts seems really finicky about the way it is added to the container. Did you add it to the lib folder of your web app or the global classpath? If you added to the classpath, then that is probably your problem.
 
Nikko Fu
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks.
the problem is solved in my colleague's computer.
so, it's my env's problem
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic