• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Quartz Sheduler not executing

 
Justin Howard
Ranch Hand
Posts: 162
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

Please help me fix the problem. I am using quartz-all-1.6.4.jar. I made sure it is there in the classpath. I also made sure the quartz.properties is present in the classpath.
I have this in my quartz.properties


I have this in the logs


I dont see any problems in the logs, but the job does not execute.

This is my initialization servlet


This is in the web.xml


Thanks!
 
Rob Spoor
Sheriff
Pie
Posts: 20659
64
Chrome Eclipse IDE Java Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Moving to Other Open Source Projects.
 
Martijn Verburg
author
Bartender
Posts: 3275
5
Eclipse IDE Java Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I would add more logger.debug statements and see exactly where it last logs something....
 
Sagar Rohankar
Ranch Hand
Posts: 2907
1
Java Spring Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
May be the Job is not getting created because of this problem
 
Justin Howard
Ranch Hand
Posts: 162
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for the reply.
The authenticate filter is just for check if the user is logged in or not.

I am using the same configuration for another project , it works fine.

Thank you.
 
Justin Howard
Ranch Hand
Posts: 162
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

I am getting an error in the web.xml for <init-param> in eclipse.


It reads ,
Invalid content type found at init-param. One of {urls} is expected.
Could that be the problem ?

Thanks
 
Sagar Rohankar
Ranch Hand
Posts: 2907
1
Java Spring Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Justin Howard wrote:Invalid content type found at init-param. One of {urls} is expected.

No, that couldn't be the problem.

I'm more interested in this logs
 
Justin Howard
Ranch Hand
Posts: 162
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you for the reply.
Those never came up in the logs. I had given a few more log statements. "Here 2" was the last staement in the logs. The PasswordReset class is present in the same package.

 
Sagar Rohankar
Ranch Hand
Posts: 2907
1
Java Spring Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Then find out why "here 3" is not getting logged out, find out why 'JobDetail' instance is not getting created. Simply try/catch the block and use System.out. statements to print.
 
Justin Howard
Ranch Hand
Posts: 162
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Sagar,

I do have a try/catch block. I did not paste that part of the code in the forum.
Earlier in the post I have posted what was coming up in the logs.

Thanks
 
Sagar Rohankar
Ranch Hand
Posts: 2907
1
Java Spring Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Its hard to say then, neither logs nor any exception trace to point out the problem.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic