Win a copy of Java 9 Modularity: Patterns and Practices for Developing Maintainable Applications this week in the Java 9 forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Struts 2.0 application not working in WAS 6.1 server  RSS feed

 
sumanta panda
Ranch Hand
Posts: 224
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear All,

I have a simple Login application developed in Struts2.0.

When I make a war file (Login.war) and deployed in tomcat 5.5 server it is working. I click the URL http://localhost:8080/Login and to submit userid and password for authentication. According to the authentication it is directed to success page.

Same war file(Login.war) when I deploy in WAS 6.1(web sphere 6.1) server it is deployed. But when I click the URL the http://localhost:9080/Login
the login.jsp page is coming.When I submit the userid and password after that it not directed to success/failure page. After submit it is showing blank page that means the action is not working.

I have tried with Struts 1.x version application deployed in WAS 6.1 it is working properly.

Any application I have developed in Struts 2.0 it is working in Tomact 5.5 server. But not working in WAS 6.1.As WAS 6.1 supported struts 2.0, I don’t understand why the action is not performed.

Please see the console log information
9/14/09 16:23:24:326 IST] 0000001f XmlConfigurat I com.opensymphony.xwork2.config.providers.XmlConfigurationProvider register Parsing configuration file [struts-default.xml]
[9/14/09 16:23:24:388 IST] 0000001f XmlConfigurat I com.opensymphony.xwork2.config.providers.XmlConfigurationProvider register Parsing configuration file [struts-plugin.xml]
[9/14/09 16:23:24:451 IST] 0000001f XmlConfigurat I com.opensymphony.xwork2.config.providers.XmlConfigurationProvider register Parsing configuration file [struts.xml]
[9/14/09 16:23:24:466 IST] 0000001f Settings W org.apache.struts2.config.Settings getLocale Settings: Could not parse struts.locale setting, substituting default VM locale
[9/14/09 16:23:24:498 IST] 0000001f BeanSelection I org.apache.struts2.config.BeanSelectionProvider register Loading global messages from com.kogent.ApplicationResources
[9/14/09 16:23:24:685 IST] 0000001f ObjectTypeDet I com.opensymphony.xwork2.util.ObjectTypeDeterminerFactory <clinit> Detected GenericsObjectTypeDeterminer, initializing it...
[9/14/09 16:23:24:701 IST] 0000001f XWorkConverte I com.opensymphony.xwork2.util.XWorkConverter getInstance Detected AnnotationXWorkConverter, initializing it...
[9/14/09 16:23:25:060 IST] 0000001f ResolverUtil I com.opensymphony.xwork2.util.ResolverUtil findInPackage Scanning for classes in [/D:/workspace_struts/PDetails/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/LoginWeb.ear/PDetailsWeb.war/WEB-INF/classes/com/kogent/action/] matching criteria: org.apache.struts2.config.ClasspathConfigurationProvider$1@17841784
[9/14/09 16:23:25:154 IST] 0000001f ServletWrappe I SRVE0242I: [LoginWeb] [/Login] [FilterProxyServlet]: Initialization successful.
[9/14/09 16:23:25:232 IST] 0000001f ServletWrappe I SRVE0242I: [LoginWeb] [/Login] [/index.jsp]: Initialization successful.


Please suggest me how to fix this error.

Thanks for your time.

Regards,
Sumanta Panda

 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Increase the logging level. What, if any, plugins are you using?
 
sumanta panda
Ranch Hand
Posts: 224
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear David,

I am using RAD 7.0 tool.I have not added any plugins.I believe all the plugins have a default setup with RAD 7.0 tool.

Please see the comple code is given below.

LoginAction.java




ApplicationResources.properties



struts.properties



struts.xml




web.xml



login.jsp


login_success.jsp


Note::I have added all the JAR files which is supported for Struts 2.0.I am not getting any compilation error.Same application if I deploy in Tomcat it is working but in WAS 6.1 server is not working.

Please suggest

Thanks for your time.

Regards,
Sumanta

[Ankit: fixed code tags]
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I meant Struts 2 plugins.

I'd recommend not using Struts 2.0.1, btw. It's quite old, and many fixes have been made.

What patch level of WAS? There was a known problem for some time. You also need to set a srever flag regarding filter compatibility, but I don't recall which flag it is. Searching the web will probably turn it up, though.
 
sumanta panda
Ranch Hand
Posts: 224
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear David,

Thanks for the prompt response.

Which version of Struts 2 Application are you suggesting me for deploy in WAS 6.1?

Please suggest.

Thanks for the understanding.


Regards,
Sumanta
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'd recommend using an up-to-date version, like maybe the latest one.

You may *still* need to set that filter compatibility flag, though, whatever it was called.
 
sumanta panda
Ranch Hand
Posts: 224
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear David,
I am working with the latest Struts 2 jar file. Still i am getting execption while deploy the application in WAS 6.1.
Please seeavid, the console log information



Please suggest.
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
2.0.6 is not the latest version, and telling me you're "using the latest version" means I have to dig through your stack trace to figure out which version you're actually using. Make it easier for people to help you.
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!