Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Endpoint {http://www.}ContentManagementService_v1_0 does not contain operation metadata for {...}

 
DhaKatta Dha
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

This is very urgent requirement. I'm wrote a webservice client for an external service using http.

I can paste the code below. I'm getting a exception shown below If I try to use the service hosted.

Exception in thread "main" org.apache.axis2.AxisFault: Endpoint {http://www.dolby.com/dcinema/ws/smi/v1}ContentManagementService_v1_0 does not contain operation meta data for: {http://www.dolby.com/dcinema/ws/smi/v1/getClipInfosResponse}getClipInfosResponse
at org.apache.axis2.util.Utils.getInboundFaultFromMessageContext(Utils.java:512)
at org.apache.axis2.description.OutInAxisOperationClient.handleResponse(OutInAxisOperation.java:370)
at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:416)
at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:228)
at org.apache.axis2.client.OperationClient.execute(OperationClient.java:163)
at org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:548)
at org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:528)
at com.dolby.www.dcinema.ws.smi.v1.testserviceClient.main(testserviceClient.java:33)


So can anybody please help me the probable cause for this type of exceptions.
Its really urgent. Please help..
Best Regards
-katta
 
Ivan Krizsan
Ranch Hand
Posts: 2198
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!
Have you tried to issue requests to the service using soapUI or some similar program?
This to isolate the problem to the client side.
Best wishes!
 
DhaKatta Dha
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ivan Krizsan wrote:Hi!
Have you tried to issue requests to the service using soapUI or some similar program?
This to isolate the problem to the client side.
Best wishes!


Hi Ivan,

Yes I tried soap UI is not even connecting to the server provider. It has some proxy prolems which I resolved in my java by setting through java code. So I could connect through eclipse but not soapUI.

But I'm trying to see what could cause such problems that I encountered about endpoint?

Could you please give me some solution?

Regards
-Katta
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic