• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

WL 10 Browser caching issue

 
Steve Arizona
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I upgraded a reporting application from WL8.1 to WL10.2 and am now having Internet Explorer caching issues.
The report is correct on the application server but the browser is opening up the local clients cached report.
I have the browser setting set to check for newer version of stored pages every time I visit the web page. The response headers are also set to no-cache within the JSP.

When I run the application in WL8.1 I don't have any issues.

Any ideas?

Thanks in Advance.
 
Deepak Bala
Bartender
Posts: 6663
5
Firefox Browser Linux MyEclipse IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I really doubt if this is a WL problem. Compare the response generated by weblogic in WL 8.1 and WL 10 using a debugging proxy like charles -> http://www.charlesproxy.com/download/. If they are the same, it is not a problem with weblogic

You can use Etags or an expires header as well.
 
Steve Arizona
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Deepak Bala wrote:I really doubt if this is a WL problem. Compare the response generated by weblogic in WL 8.1 and WL 10 using a debugging proxy like charles -> http://www.charlesproxy.com/download/. If they are the same, it is not a problem with weblogic

You can use Etags or an expires header as well.


Thanks for the Response Deepak.
I download Charles and viewed the response headers as shown below:

WL8.1
1st run response raw
HTTP/1.1 200 OK
Date: Thu, 24 Sep 2009 16:56:55 GMT
Content-Length: 164564
Last-Modified: Thu, 24 Sep 2009 16:56:43 GMT
Connection: Close

<HTML>
<BODY>
<table>
<tr>
<td>



2nd run response raw

HTTP/1.1 200 OK
Date: Thu, 24 Sep 2009 16:57:46 GMT
Content-Length: 33506
Last-Modified: Thu, 24 Sep 2009 16:57:38 GMT
Connection: Close

<HTML>
<BODY>
<table>
<tr>
<td>

//WL 8.1 successfully writes out and has no issues.

WL10.2
1st run response Raw
HTTP/1.1 200 OK
Connection: close
Date: Thu, 24 Sep 2009 17:01:23 GMT
Content-Length: 164564
Last-Modified: Thu, 24 Sep 2009 17:01:20 GMT
X-Powered-By: Servlet/2.5 JSP/2.1

<HTML>
<BODY>
<table>
<tr>
<td>
<table BORDER="1">
<tr>
<td>



2nd run response


HTTP/1.1 304 Not Modified
Connection: close
Date: Thu, 24 Sep 2009 17:07:25 GMT
Content-Length: 0
X-Powered-By: Servlet/2.5 JSP/2.1

//WL10.2 thinks the file that it's attempting to serve to the client hasn't changed as the file name is the same.

After the clients local cache is deleted:

3nd run response

HTTP/1.1 200 OK
Connection: close
Date: Thu, 24 Sep 2009 17:09:10 GMT
Content-Length: 164564
Last-Modified: Thu, 24 Sep 2009 17:01:20 GMT
X-Powered-By: Servlet/2.5 JSP/2.1

<HTML>
<BODY>
<table>
<tr>
<td>

It appears that WL10 can't overwrite what's in the clients Local Settings\Temporary Internet Files whereas 8.1 can.


Any ideas?
 
Deepak Bala
Bartender
Posts: 6663
5
Firefox Browser Linux MyEclipse IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There dont seem to be any additional headers that indicate that a problem is at hand. If I remember correctly, weblogic allows you to tweak a caching setting through weblogic.xml or a similar configuration file. mmm... now if only I could remember what the caching config element was. If I can remember it I ll post here. The element affects the way weblogic caches its content and the response codes that it sends out to you
 
Steve Arizona
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Deepak Bala wrote:There dont seem to be any additional headers that indicate that a problem is at hand. If I remember correctly, weblogic allows you to tweak a caching setting through weblogic.xml or a similar configuration file. mmm... now if only I could remember what the caching config element was. If I can remember it I ll post here. The element affects the way weblogic caches its content and the response codes that it sends out to you


The issue has now been resolved. I added the below parameters to the weblogic.xml:
<container-descriptor>

<resource-reload-check-secs>0</resource-reload-check-secs>

</container-descriptor>
 
Deepak Bala
Bartender
Posts: 6663
5
Firefox Browser Linux MyEclipse IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you for sharing the solution
 
Consider Paul's rocket mass heater.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic