Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

'Open Resource...' in Eclipse

 
Anand K Gupta
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can we enable 'Open Resource...' for perspectives other than Java perspective?
 
Tauseef Syed
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The "Open Resource" is enabled for all the perspectives, I use Eclipse 3.3.2.
Might be the control was not on the eclipse Editor when you hit the key, else it should just work fine.
 
Anand K Gupta
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I m using eclipse 3.5, and its not enabled for all perspectives. Only for Java perspective it is enabled.

 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I could use a little more clarification - what do you mean by "Open Resource"? Where, and under what circumstances, do you see this option? I looked through the main menu and various context menus and have not found such an option.
 
Anand K Gupta
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
that's what i told, if u'l switch to java perspective then only it is enabled, under menu item Navigate-> Open Resource
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
OK, now that you told me where to look I see it. I was in "Java EE" and then tried "Java" and "Resource" perspectives and it was there on all three. But not in "Team Synchronizing".

While in a perspective that doesn't show the desired menu item, go to Window | Customize Perspective. Then in the Menu Visibility tab, expand Navigate and then click on the grey-out Open Resource entry. A dialog box will pop up that tells you which Command Group that menu item belongs to. Then go to the Command Groups Visibility tab, find that command group and check it. Then click Ok on the dialog box. You should then have that menu option.

 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic