• Post Reply Bookmark Topic Watch Topic
  • New Topic

setting parent in custom schema  RSS feed

srini carry
Ranch Hand
Posts: 83
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I created my custom schema , a parser , a name space handler , it works fine all my beans are initialized.now I want to add the feature of parent(inheritance ) to my custom schema , I found a method getParentName from AbstractSingleBeanDefinitionParser , I override this method to set the parent , when I debug I can see the parent is set , but when all the beans are loaded and I call get methods of child bean I get null even tough the parent is set child is not inheriting , I d'ont what is going wrong ,
I also tried the same with beans not my custom schema it worked fine the child inherited from parent but in case of my custom schema its not, please suggest me with some examples , or any hints on what might cause this , help is greatly appreciated.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!