• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Rob Spoor
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Henry Wong
  • Liutauras Vilda
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Tim Holloway
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Mikalai Zaikin
  • Piet Souris

Problem with MyEclipse 7.5 and Debugging (debugging doesn't work!)

 
Bartender
Posts: 1829
17
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello,

As a long-time MyEclipse user, I was quite sad to see that when Apple came out with Snow Leopard (OS/X 10.6, now 10.6.1), I was no longer able to debug using MyEclipse 7.5.

The error I got when starting the debugger after putting a break point on a line of code was "Cannot connect to VM".

I worked with Riyad Kalla at Genuitec most of last weekend trying to solve this basic debug problem. Riyad is a truly dedicated professional and he tried diligently to help figure this problem out. Having worked with him this last weekend, it appears that the debug issue may be the Apple JVM 1.6 and possibly also with a Carbon-based (Mac) implementation like MyEclipse.

I was able, for example, to debug using the "Cocca" version of standard Eclipse.

Naturally, I disabled the Mac firewall and even un-installed the outgoing 3rd party firewall "Little Snitch" to make sure that it wasn't casing any of the problems.

So, my question is....has anyone else had the "Connect Connect to VM" problem with MyEclipse? I really don't want to give up on MyEclipse.

Thanks to all in advance for any help or suggestions!!!

-- M
 
Don't get me started about those stupid light bulbs.
reply
    Bookmark Topic Watch Topic
  • New Topic