Win a copy of Kotlin in Action this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Binding to multi-D array  RSS feed

Matthew Tripp
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

I've searched through various threads and did not find anything that answers my problem. PLease forgive if I missed something that actually tells me the answer.

So I'm trying to bind to a formbacking object that contains a multidimensional array. Well not a multi dimensional array, but I've got an object with a list of another kind of objects, and each of these objects also has a list. (is there a term for this sort of construct)

so something like this.

So in my controller I have something like

Now... I have a form into which I want to bind some form:inputs to the properties in the gicklewick lists.

something like this

I have tried the above and it devolves into a number format exception caused by the machinations in the form:input line within the inner foreach. I have also tried

no joy there, with the same exception on the same line as the first example.

note that this

does not cause any errors, and shows the correct value of, in this case, gork.

So I can display, but I cannot figure out how to bind. Anyone worked through something like this?

Thanks in advance.

  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!