• Post Reply Bookmark Topic Watch Topic
  • New Topic

doing the servlet exercises  RSS feed

 
Benjoe Reyes
Ranch Hand
Posts: 109
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i have downloaded the orion server and got it running then i placed my NowServlet class file in
c:\orion\default-web-app\WEB-INF\classes\
and my NowServlet.htm file in
c:\orion\default-web-app\
but when i clicked the button to get the date & time i get the "page cannot be found" message instead...
the following are my java and html codes respectively:

(code removed by Marilyn-post pseudocode and snippets only please)
<FORM
ACTION="http://localhost:8080/servlet/NowServlet"
METHOD="GET">

why is it that everytime i turn around the corner things go BLAM!!! ???
* i changed the "<" to "&It" because i get error messages in posting my message due to tags...
[ January 03, 2003: Message edited by: Benjoe Reyes ]
[ January 04, 2003: Message edited by: Marilyn de Queiroz ]
 
Marilyn de Queiroz
Sheriff
Posts: 9082
12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Were you able to see the BeeServlet? I wonder because Orion's default is port 80, not port 8080.
 
Dirk Schreckmann
Sheriff
Posts: 7023
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
why is it that everytime i turn around the corner things go BLAM!!! ???
Well, just imagine how boring life would be if everything were perfectly as you liked it.
 
Benjoe Reyes
Ranch Hand
Posts: 109
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
port num = 80 not 8080? i'm getting crosseyed
thanks
when things go BLAM!!! i get down time and that's boring , i'm stuck waiting for replies( though i really appreciate them)
[ January 09, 2003: Message edited by: Benjoe Reyes ]
 
Pauline McNamara
Sheriff
Posts: 4012
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I used orion with the port set to 8080, but it was something that had to be set explicitly (in the default-web-site.xml file, I think).

In your form you have:
ACTION="http://localhost:8080/servlet/NowServlet"
Not sure why you're using an absolute path in the html form. Have you tried
ACTION="/servlet/NowServlet" ?

Pauline
PS On being bored, a little quote from Goethe:
"Thinking is more interesting that knowing, but less interesting than looking."
 
Pauline McNamara
Sheriff
Posts: 4012
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Marilyn de Queiroz:
Were you able to see the BeeServlet?
 
Benjoe Reyes
Ranch Hand
Posts: 109
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i'm on servlet 3 now. i tried to copy and embedd Reverse2.htm in my servlet program so continued clicking the button would cycle through the reverse and unreversing of the text but it won't happen. i've been thinking of using showDocument() but i can't find a way to pass the text value
any tips?
[ January 11, 2003: Message edited by: Benjoe Reyes ]
 
Marilyn de Queiroz
Sheriff
Posts: 9082
12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You mean showDocument() as in javascript?

You need to find a way to embed your html (not the html page) into your servlet.
 
Consider Paul's rocket mass heater.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!