• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

rowset.jar with jdk1.4

 
amarshi mohanty
Ranch Hand
Posts: 110
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,
My Application is built in jdk 1.4.Now there is a requirement for CachedRowSet for which i am using rowset.jar (as CachedRowSet is supported from jdk1.5 onwards).
there isn't any error displayed on the Eclipse IDE, but when i am building the application (running build.xml) its displays error as

cannot resolve symbol
CachedRowSet crs1 = new CachedRowSetImpl();
^

I even imported the
com.sun.rowset.CachedRowSetImpl and javax.sql.rowset.CachedRowSet;

I also added rowset.jar to the project classpath

Is it because i am using jdk 1.4 its showing the error.
Its there any solutin for using CachedRowSet in JDK 1.4 apart from using rowset.jar.
 
Ulf Dittmer
Rancher
Posts: 42968
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It sounds like the Ant build file does not include the required jar file - check the classpath it uses.
 
amarshi mohanty
Ranch Hand
Posts: 110
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
In the build.xml i am specifying the path of the parent folder , and i have kept rowset.jar in it.


Thanks
Amarshi
 
Ulf Dittmer
Rancher
Posts: 42968
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you want to include jar files, then specifying the path doesn't work - you have to specify the actual jar file. Specifying directories only causes loose class files in them to be included, but not any jar files.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic