Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Issues configuring tomcat 5.5 server with Eclipse europa

 
sulabh kapoor
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have added "tomcat 5.5.28 - deployer" in my F drive at location "F:\apache-tomcat-5.5.28-deployer" but i am getting the error
"The Tomcat installation directory is not valid. It is missing expected file or folder common/i18n."

As suggested i have set the classpath also but it stills give me the same error.
I have installed eclipse europa.

Please help me.
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You need to install Tomcat, not the Tomcat Deployer.
 
sulabh kapoor
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
Can you please provide me the exact link from where i can download tomcat. I have tried two -three versions but none is working.
Thanks in advance.
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No, because Apache would prefer you to use a mirror.

Use the "core" download from here: http://tomcat.apache.org/download-55.cgi
 
sulabh kapoor
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks.. It has started working. But one minor issue. The error of port already being used is there. how to get rid of this now..
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Stop the previously-running Tomcat instance.
 
sulabh kapoor
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
there is no previous instance running. i have stopped the server from services.msc also. it still says the same issue that port number is already in use and server is already running.
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Then there's a previous instance running, or something else is using the port.
 
sulabh kapoor
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
any idea how to locate what is running.
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
To find out what apps are using which ports, open a command prompt and run:

netstat -anb

Or better yet, get TCPView from sysinternals - it displays the same info in a GUI.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic