Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

WSDL OK, but method is not supported

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
An existing web service GetStuff exists and runs as expected, but the exact copy of it GetOtherStuff does not.

GetOtherStuff appears in the generated WSDL and has been added to the method list (as required in this implementation) - but the response is:

<SOAP-ENV:Fault>
<faultcode>SOAP-ENV:Server</faultcode>
<faultstring>Method 'GetOtherStuff' is not supported.</faultstring>
<faultactor>/OSMQSoap/rpcrouter</faultactor>
</SOAP-ENV:Fault>

This seems to indicate the WSDL is OK with regard to GetOtherStuff, but the service is still not exposed properly. Any suggestions?

Googling has brought nothing - possibly because the web services are deployed on an ancient Tomcat (version 3) using Axis 1 (I believe). Upgrading is unfortunately not an immediate option.
 
Morten Sorensen
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Problem solved.

The file DeployedServices.ds needed to be re-generated.
 
And tomorrow is the circus! We can go to the circus! I love the circus! We can take this tiny ad:
the value of filler advertising in 2020
https://coderanch.com/t/730886/filler-advertising
    Bookmark Topic Watch Topic
  • New Topic