Win a copy of Machine Learning Systems: Designs that scale this week in the Scala forum
or Xamarin in Action: Creating native cross-platform mobile apps in the Android forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Getting Time Out Exception while Remote Debugging in Eclipse  RSS feed

 
Ranch Hand
Posts: 2234
Eclipse IDE Firefox Browser Redhat
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi i am using MyEclipse6.0 and Weblogic 11g .

I deployed an application in an application server and wants to debug the application from the Eclipse IDE using the RemoteDebugger .

Added some break points to my servlet .

Somehow i am geting error Timeout Exception .

The steps i followed is :

1. From the Menu I clicked on Debug As Icon and selected Open Debug Dialog.
2. From Remote Java Application , I clicked New
3. Given some Name ,
4. Under connect tab , Given the Host and port , broswed to the approiate Project
5.Under source Tab , Added the source ,
6.Under Common Tab , clicked LOcal File , checked Debug Option ,clicked Appply and Debug.

I am getting

Failed to connect to remote VM. Connection timed out.
org.eclipse.jdi.TimeoutException


Please help me .
 
Bartender
Posts: 19454
88
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This could be:

1. You didn't start the remote application with remote debugging enabled.

2. You are trying to connect to the wrong tcp/ip port on the remote machine.

3. You have a firewall blocking the connection.
 
Ravi Kiran Va
Ranch Hand
Posts: 2234
Eclipse IDE Firefox Browser Redhat
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This has been a big big problem for me . Till now i am using System.out.println statements and i am fed up .Please help .

You didn't start the remote application with remote debugging enabled.



Please tell me how can i make sure the above one .I am using weblogic 10g
 
Tim Holloway
Bartender
Posts: 19454
88
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Ravi Kiran Varre wrote:
Please tell me how can i make sure the above one .I am using weblogic 10g



I haven't looked at WebLogic lately, but if you ask in the WebLogic forum, someone should be able to tell you.
 
Ravi Kiran Va
Ranch Hand
Posts: 2234
Eclipse IDE Firefox Browser Redhat
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you . i will post into it .
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!