Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

commons-looging version issue during a maven build

 
Jeevan Sunkersett
Ranch Hand
Posts: 78
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Hi,

In the project in hand, I use Maven 2.0.9 as the build framework.

But a maven compile terminates with this error below;

I am unable to locate where 2 versions off commons-logging is being referred.

Checked all POMs to ensure that <dependency> on 'commons-logging' uses only <version> 1.0.4

But it seems somewhere version 1.0.3 is being refrenced implicitly.

Any pointers how to find the culprit code/ pom?

thanks
~g1


 
Martijn Verburg
author
Bartender
Posts: 3275
5
Eclipse IDE Java Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try 'mvn dependency:analyze'
 
Jeevan Sunkersett
Ranch Hand
Posts: 78
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks.

But it did not take me any further as the build terminated with the same exception .... (2 versions of common-logging used, which is not allowed)

 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic