• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Getting javax.naming.CommunicationException Using Jboss 4.0.5

 
nav katoch
Ranch Hand
Posts: 246
Eclipse IDE Java Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I am getting the following error after running "ant run" in command prompt while running chapter 1 on jboss 4.0.5GA of ejb 3 in action:-

[java] javax.naming.CommunicationException [Root exception is java.lang.ClassNotFoundException: org.jboss.ejb3.JBossProxy (no security manager: RMI class loader disabled)]
[java] at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:728)
[java] at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:587)
[java] at javax.naming.InitialContext.lookup(InitialContext.java:392)
[java] at com.ejb3inaction.actionbazaar.client.HelloUserClient.main(HelloUserClient.java:16)
[java] Caused by: java.lang.ClassNotFoundException: org.jboss.ejb3.JBossProxy (no security manager: RMI class loader disabled)
[java] at sun.rmi.server.LoaderHandler.loadProxyClass(LoaderHandler.java:535)
[java] at java.rmi.server.RMIClassLoader$2.loadProxyClass(RMIClassLoader.java:628)
[java] at java.rmi.server.RMIClassLoader.loadProxyClass(RMIClassLoader.java:294)
[java] at sun.rmi.server.MarshalInputStream.resolveProxyClass(MarshalInputStream.java:238)
[java] at java.io.ObjectInputStream.readProxyDesc(ObjectInputStream.java:1531)
[java] at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1493)
[java] at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1732)
[java] at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1329)
[java] at java.io.ObjectInputStream.readObject(ObjectInputStream.java:351)
[java] at java.rmi.MarshalledObject.get(MarshalledObject.java:142)
[java] at org.jnp.interfaces.MarshalledValuePair.get(MarshalledValuePair.java:72)
[java] at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:652)
[java] ... 3 more

It has been deployed fine using "ant" in command prompt.

Please help to fix this problem,

Thanks a lots,

Naveen
PS: Eventually, I tested with jboss 4.2.2 and It's working fine. Am I missing something?
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic