Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

problem with ant, junit, NetBeans, Java, or me

 
Ranch Hand
Posts: 32
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I see you have forums for ant, junit, and NetBeans. Rather than crosspost, I'll start here. I have a Java project underway, 15 classes so far, developed in NetBeans. About 12 have been thoroughly tested by junit tests constructed from skeletons provided by NetBeans. Now instructor says use ant to make the package to turn in. Just take this and make a few obvious tweaks. After some tweaking, I still can not get the tests to run. Error messages indicate that all the test programs are found. I think the problem lies in the line that begins <jvmarg in the following fragment from the supplied file, but I don't know what it is supposed to mean.



A pointer to the correct forum, or even an explanation would be great. Thanks.
 
Author
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It might make sense to include what's actually happening.
 
Charles Bradley
Ranch Hand
Posts: 32
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Here is the ant output, cut off after two of the tests.


... for about a dozen more, then


This file is unknown to me:
.Users.sam.Desktop.spell.config.configuration.properties
If I knew what it was supposed to contain, I probably could figure out a place to put that content.
Thanks.
 
David Newton
Author
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It's probably supposed to contain JVM arguments--if you don't need any JVM args then you may not need the file at all.

http://ant.apache.org/manual/OptionalTasks/junit.html#nested
 
Charles Bradley
Ranch Hand
Posts: 32
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Commenting out the mysterious line allowed the tests to run. Thanks.

Now I'll take a detour to find out why the idea of "write once, run anywhere" is compatible with the JVM having arguments, and then I can go back to finding out why the test results from the ant script do not match the results when I run the test from within NetBeans. This is not a request for help; I might be back, but I need to do some research first. Thanks again.
 
Marshal
Posts: 70292
282
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Too difficult a question for "beginning". Moving.
 
Remember to always leap before you look. But always take the time to smell the tiny ads:
the value of filler advertising in 2020
https://coderanch.com/t/730886/filler-advertising
    Bookmark Topic Watch Topic
  • New Topic