Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

URL Pattern Not recongonized

 
pradeep chellappan
Greenhorn
Posts: 29
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi ,

I am using a Client proprietary MVC framework to build my webapplication.

Issue:

The Http request sent from the client is not hitting the server and i am getting standard 404 File not found Error while clicking the submit button in my launch page. The Url that is generated upon submitting the request from launchpage.html is something like:

http://localhost:9080/<Webapp-Context Root Name>/execute.do?param1=value1¶m2=value2


I have the following in my web.xml and nothing else.

<servlet>
<servlet-name>someservlet</servlet-name>
<servlet-class>dummyservlet</servlet-class> //assume that dummyservlet is the front controller serlvet
<servlet>
<servlet-mapping>
<servlet-name>someservlet</servlet-name>
<url-pattern>*.do</url-pattern>
</servlet-mapping>

I have cross checked that atleast my WAR structure is fine. My web applicaiton has the following structure

sampleapplicationweb
javasource
webcontent
META-INF
WEB-INF
lib
web.xml
jsps
launchpage.html

I am using IBM RSA6.0 So, websphere is my Application server. I have done many examples like this in the past,but unable to figure out why the request is not hitting the server for this particular one.

Please let me know what could be the reason for this scenario to occur. What have i done wrong.

Thanks in Advance!

raminjavac
 
luke yu
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I think it's difficult to debug without log
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic