• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Liutauras Vilda
  • Knute Snortum
  • Bear Bibeault
Sheriffs:
  • Devaka Cooray
  • Jeanne Boyarsky
  • Junilu Lacar
Saloon Keepers:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
  • salvin francis
Bartenders:
  • Tim Holloway
  • Piet Souris
  • Frits Walraven

An Issue(?)

 
Rancher
Posts: 1369
1
Android Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When I clicked My Posts, I was taken to "Messages posted by Manisha Gupta" page! I reloaded thrice but to no avail.

I clicked "My Posts" while drafting this thread and got My Posts listed correctly.

Is there an issue with the forum software?

 
Rancher
Posts: 425
Android Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Monu Tripathi wrote:When I clicked My Posts, I was taken to "Messages posted by Manisha Gupta" page! I reloaded thrice but to no avail.

I clicked "My Posts" while drafting this thread and got My Posts listed correctly.

Is there an issue with the forum software?



Maybe the server thought you were someone else! And then he (or is it a she??) realized his (her) mistake!

But seriously, I just tried clicking on My Posts from 4-5 random places in the forum. Got my posts listed correctly every time. The server knows me quite well!!
 
Bartender
Posts: 6663
5
MyEclipse IDE Firefox Browser Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have never had a problem with it.

When I clicked My Posts, I was taken to "Messages posted by Manisha Gupta" page!



I looked at the logs and the forum software's DNA analysis code was able to verify that you and Manish are related with a 87% accuracy. That is probably what caused the problem if you were to browse from Australia you would see Manish's profile 87% of the time.
 
Bartender
Posts: 11445
19
Android Google Web Toolkit Mac Eclipse IDE Ubuntu Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I wonder if I should be sending Monu a "Please check your private messages...." PM

On a more serious note, is this problem reproducible on demand or was it a one off occurrence?
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Monu Tripathi wrote:When I clicked My Posts, I was taken to "Messages posted by Manisha Gupta" page! I reloaded thrice but to no avail.



Do you know that other person? More specifically, is the system that you used a shared one? Maybe it was used by Manisha earlier (with remember my login feature)? That however doesn't explain why you started seeing the correct behaviour while drafting the post.
 
Monu Tripathi
Rancher
Posts: 1369
1
Android Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Maneesh Godbole wrote:On a more serious note, is this problem reproducible on demand or was it a one off occurrence?


This is the second time. It occurred yesterday and today in the morning. It is working as designed, at the moment.
Unfortunately it is not frequent enough to be reproducible on demand. I think it appears on my first visit to the page(I know that the browser is indifferent to the notion of mornings but what about first visits?).

Maneesh Godbole wrote:I wonder if I should be sending Monu a "Please check your private messages...." PM


M'lord, I am innocent.

Deepak Bala wrote:..DNA analysis code was able to verify that you and Manish are related with a 87% accuracy... if you were to browse from Australia


Two things: You missed a very important "a" in your analysis!
Now, I know where you've hidden your secretary! Ha!

Pushkar Choudhary wrote:Maybe the server thought you were someone else!


Yeah right, Idiosyncrasies of a machine!
 
Monu Tripathi
Rancher
Posts: 1369
1
Android Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Jaikiran Pai wrote:
Do you know that other person? More specifically, is the system that you used a shared one? Maybe it was used by Manisha earlier (with remember my login feature)?


I did check that before posting here; I don't know the person neither does my OS. I don't see a user folder of the aforementioned person in C:\Documents and Settings. The machine is dedicated to me and I don't think any one else has used it.

Jaikiran Pai wrote:That however doesn't explain why you started seeing the correct behaviour while drafting the post.


Exactly.
 
Ranch Hand
Posts: 15304
6
Mac OS X IntelliJ IDE Chrome
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The next time it happens, note the URL and the last value on the URL which is your member ID. I'd be curious to know if it is pulling the wrong user for a member ID or if you are getting an incorrect member ID when clicking the My Posts link.
 
Monu Tripathi
Rancher
Posts: 1369
1
Android Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Gregg Bolinger wrote:The next time it happens, note the URL and the last value on the URL which is your member ID. I'd be curious to know if it is pulling the wrong user for a member ID or if you are getting an incorrect member ID when clicking the My Posts link.



Sure will. I logged in twice on JavaRanch since I started this thread but I did not notice any aberrations in viewing My Posts.
 
Monu Tripathi
Rancher
Posts: 1369
1
Android Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Okay this has resurfaced again. This time I was able to save the URL and took a screen shot as well.
URL: https://coderanch.com/forums/posts/listByUser/214496

When I tried "My Post" from different machine it worked fine.

My browser was Mozilla Firefox 3.5 and it is having trouble remembering who I am!

javaranch.jpg
[Thumbnail for javaranch.jpg]
 
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

I don't see a user folder of the aforementioned person in C:\Documents and Settings.


That has nothing to do with it. He could log into your machine using your account, and log in Javaranch using his account.

The machine is dedicated to me and I don't think any one else has used it.


You don't think ? Or you're 100% sure ? Where is this machine ? At home ?
 
Monu Tripathi
Rancher
Posts: 1369
1
Android Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Christophe Verré wrote:You don't think ? Or you're 100% sure ? Where is this machine ? At home ?


I think, I am sure
100% sure; this machine is at my worksplace and I am in office for the most part of my day. Also, I am pretty sure there is no one around me with that name.
 
Jaikiran Pai
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Monu Tripathi wrote:
I think, I am sure
100% sure; this machine is at my worksplace and I am in office for the most part of my day.



Are you behind a proxy server at your workplace? I guess you are. The next time you run into this, can you try clearing the cookies from your browser and see if that solves the issue?

 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When this happened, did you logged in ? or were you already logged in from a previous session ?
 
Monu Tripathi
Rancher
Posts: 1369
1
Android Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes, I had just logged into JavaRanch, visited a couple of forums, then clicked on "My Post" which led to this.

Also, there are some issues with my browser settings; it doesnot "remember me for every visit" even when I click the "checkbox" on login page.
 
Monu Tripathi
Rancher
Posts: 1369
1
Android Eclipse IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Jaikiran Pai wrote:

Monu Tripathi wrote:
I think, I am sure
100% sure; this machine is at my worksplace and I am in office for the most part of my day.



Are you behind a proxy server at your workplace? I guess you are. The next time you run into this, can you try clearing the cookies from your browser and see if that solves the issue?


Yes, I am behind a proxy server and I can do that.
 
That's a very big dog. I think I want to go home now and hug this tiny ad:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!