• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Junilu Lacar
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Rob Spoor
  • Bear Bibeault
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Piet Souris
  • Carey Brown
  • Stephan van Hulst
Bartenders:
  • Frits Walraven
  • fred rosenberger
  • salvin francis

Cannot find ActionMappings or ActionFormBeans collection

 
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
my struts-config.xml:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE struts-config PUBLIC "-//Apache Software Foundation//DTD Struts Configuration 1.1/EN" "http://jakarta.apache.org/struts/dtds/struts-config_1_1.dtd">
<struts-config>
<form-beans>
<form-bean name="loginform" type="calvin.Loginform" />
</form-beans>
<action-mappings>
<action path="/Login" type="calvin.LoginAction" name="loginform" >
<forward name="success" path="/index.jsp" />
</action>
</action-mappings>
<message-resources parameter="ApplicationResource.properties" />
</struts-config>
index.jsp:
<html:form action="Login" name="loginform" type="calvin.Loginform">
UserName: <html:text property="username"/>
Password: <html assword property="password"/>
</html:form>

Exception: Cannot find ActionMappings or ActionFormBeans collection  
Can anybody tell where is the problem? Thanks a lot.
 
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hi,
u have to append .do to ur action ie.,
Login.do & try it will work
 
Ranch Hand
Posts: 228
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Is the location of u'r struts-config in your web.xml and if it is is it proper? the form and the action mapping and the jsp all seem fine, YOU DO NOT NEED TO DO A .do IF YOU ARE USING A STRUTS FORM TAG.
Sahil
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
check your web.xml file and make sure that all your references to your "WEB_INF" subdir are CAPITALIZED. The application cannot read the struts-config.xml file if it referenced as '/web-inf/struts-config.xml'
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello,

this error also occurs if you don't include some jar-files like commons-*.jar that struts need.

I think that the Exception is not useful in this context.


Good night

Andreas
 
Ranch Hand
Posts: 51
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
i m getting the same error but the reason is different i m using multiple buttons and for that in Action class i m having different methods (other then execute) so it might be realted to that...
i need help on this as its not working...n yes m using 1.2.9 version of sturts.. do i need to add any additional jars for this???
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I had the same problem. My app was working on wsad bot not on RAD.
And in web.xml file
I changed the following lines
<init-param>
<param-name>config</param-name>
<param-value>WEB-INF/struts-config.xml</param-value>
</init-param>
to
<init-param>
<param-name>config</param-name>
<param-value>/WEB-INF/struts-config.xml</param-value>
</init-param>
It worked for me

-Kiran Kanukuntla
 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I also faced same error , Actually what I did is declared a property twice
<form-property name="uname" type="java.lang.String" />
<form-property name="uname" type="java.lang.String" />


I removed It and problem solved
reply
    Bookmark Topic Watch Topic
  • New Topic