This week's book giveaway is in the OCAJP forum.
We're giving away four copies of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) and have Khalid A Mughal & Rolf W Rasmussen on-line!
See this thread for details.
Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem in JSP page is using the 'struts bean' tag library

 
nilesh jainn
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi
I am working on a web application which is not developed by me. This application is working fine on production server, however when i am deploying the same on a different environment, it is not working appropriately.

The web-application is using Struts, struts tiles, Struts bean etc tag-library.

The problem which I am reffering to:
JSP page is using the 'struts bean' tag library hence I am specifying the tag lib on the top as:
<%@ taglib uri="/WEB-INF/struts-bean.tld" prefix="bean" %>
which is retrieveing the value by passing key as:
<bean:message key="key1"/>

When I am reffering the same jps it is throwing an error:
[ServletException in:layout.jsp] Missing message for key "key1"'

However when I am looking at the ApplicationResources.properties it is containing the key and value.

I understand that this is a very generic way of explaining the problem. I urge if someone, Could someone look at the problem suggest the pointer or at least revert and suggest more information if I am missing something.

Thanks.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic