• Post Reply Bookmark Topic Watch Topic
  • New Topic

ibatis problem on axis2  RSS feed

 
Reza Mochamad Diannagara
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi,

i'm trying to build a simple web service using ibatis. but, i found some problem.
on the first try, it couldn't found SQLMapConfig.xml. then i try these codes:


it could fix the problem, but there are another problems appear. since there are this line of codes in SQLMapConfig.xml :

and


then it couldn't found SqlMapConfig.properties and maps.xml files.
can some body help me?

oh, i put it all aar file. webservice implementation class skeleton si under "/com/webservice".

thanks...
 
Hsien Ko
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try this URL

http://www.5341.com/msg/197521.html

Overall speaking put all your class, xml and jar into Axis2\WEB-INF but NONE of them in aar file. This breaks the Axis2 module isolation but it is not a very useful feature at real-world deployment.

Axis2 is a pure-engineering product (just look at all the buzz words they create), they never realize how the real world works. The way they manage the class loader is really a disaster, engineers have fun to play around their toys at the sandbox but never try to figure out how to make it work in real life. I am going to move to CXF or JAX-WS instead of using Axis2
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!