• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Problem running ant script chapter 1 of ejb 3 in action with weblogic 10

 
Ranch Hand
Posts: 246
Eclipse IDE Oracle Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

Thanks for your time. I am getting the following while running ant script:-

C:\forWLSEJB3\chapter1>ant
Buildfile: build.xml

common:
[echo] BuildName: chapter1
[echo] BuildHome: C:\forWLSEJB3\chapter1
[echo] BuildFile: C:\forWLSEJB3\chapter1\build.xml
[echo] BuildJVM: 1.6

java-env-check:

init:
[echo] -----> Initializing project properties

setup:
[echo] -----> Creating the required sub-directories

compile-ejb-classes:
[echo] -----> Compiling EJBs

ejb-descriptor:

package-ejb:
[echo] -----> Create EJB jar file

compile-cli-classes:

cli-descriptor:

package-client:

package-app:

deploy:

BUILD FAILED
C:\forWLSEJB3\chapter1\build.xml:233: Problem: failed to create task or type wldeploy
Cause: The name is undefined.
Action: Check the spelling.
Action: Check that any custom tasks/types have been declared.
Action: Check that any <presetdef>/<macrodef> declarations have taken place.


Total time: 2 seconds

Please guide me to fix this problem.

Thanks again,

Naveen Katoch
 
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Did you download the correct source ? I mean these.
 
nav katoch
Ranch Hand
Posts: 246
Eclipse IDE Oracle Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Christophe,

Thanks for your time. Yes, I have downloaded the source code from the same link/cite. I have already resolved the issue.

Thanks again,

Naveen
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

I have already resolved the issue.


Can you share it here ? This could help other ranchers facing the same problem.
 
nav katoch
Ranch Hand
Posts: 246
Eclipse IDE Oracle Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Christophe,

Thanks for your time. Initially, I followed all the steps given by Debu Panda in his cite. What I did and learned from this error which is as below:-

1. I googled and came to know from one cite that I should use ant version 1.6.5 instead of 1.7 which gave me a little more details about this task/type of wldeploy.
2. Originally, I ran SetExamplesEnv script in $BEA_HOME/wlserver_10.0/samples/domains/wl_server directory to run the examples. Then I opened another command prompt window to build and deploy examples of chapter 1 using ant and I got the error which I have mentioned in my first post at the top. I changed the ant version to 1.6.5 to run it again and got to know a little more from the errors given by ant.
3. This time I didn't change the dos window, I changed directory to chapter 1 and ran ant script to build and this time worked fine but some other exceptions pertaining to weblogic.
4. Now I changed back to ant version 1.7, it worked with it too but with same weblogic exceptions. But I haven't worked on those yet as this weblogic is consuming a lots of memory and slows down the system, so I have to wait. Nothing changed by changing ant version.

What I learned from my experience is that the weblogic like websphere is heavy product as compare to jboss or glassfish as I have been using all of these to see the difference with different servers. I may be wrong. These are my observations.

Now I will work on exception's stuff. See what happens.

Thanks again,

Naveen

 
nav katoch
Ranch Hand
Posts: 246
Eclipse IDE Oracle Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I got the following errors after ant and ant run:-



Any inputs will highly be appreciated to fix it.

Thanks again for your precious time,

Naveen
 
nav katoch
Ranch Hand
Posts: 246
Eclipse IDE Oracle Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I have been waiting for any inputs/suggestions.

Thanks,

Naveen Katoch
    Bookmark Topic Watch Topic
  • New Topic