Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Memory Issue

 
Marc Heruela
Ranch Hand
Posts: 38
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello guys,

Im having this weird problem. We've developed a system that is behaving really awkwardly.
On our local it runs like a precious gem (it runs fine), but when we upload it in a server (my manager told me it's a very powerful linux server),
it has a memory issue. First minute after successfully starting tomcat (5.5), we can test the system, but after sometimes, it hang up.

Im just wondering why this is the case. We have developed 3 projects previously and all are running fine on the same server whenever uploaded.
The only differences I can think of (the only difference apparent to me), is the transactional part of my applicationContext.xml.

As you can see, in my previous projects, when I declaritively make my services transactional, I will only specify the package name, and all
transactional services are stored there. In this project, our lead asked us to group services based on logic, so it turned out a lot of packages and classes.
So when i declaratively make my services transactional, i had a lot <aop:advisor>. Just wanna confirm if this really is the one causing the memory issue?
But it's working fine on our local machine (VISTA). Sorry if the question seems stupid but im running out of idea.

Thanks for any response,
-marckun
 
Marc Heruela
Ranch Hand
Posts: 38
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Here's the significant part of my applicationContext.xml



Thanks,
-marckun
 
Nathan Pruett
Bartender
Posts: 4121
IntelliJ IDE Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What kind of memory issues are you experiencing? Exceptions? Symptoms?
 
Marc Heruela
Ranch Hand
Posts: 38
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Nathan Pruett wrote:What kind of memory issues are you experiencing? Exceptions? Symptoms?


Hi

Sorry for the late reply.. but it seems that one of our developer took the connection from the framework, used it and did not close that resource, hence the memory issue after some time the server starts. already fixed the code to not let our code handle the connection..

 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic