Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

"No configuration found for the specified action" error in struts2

 
Harvinder Singh g
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
HI,

Iam getting WARNING:" No configuration found for the specified action: 'loginAction' in namespace: '/login'. Form action defaulting to 'action' attribute's literal value." when my login page opens which is the first page when application starts. I have tried various values for namespace in struts-login.xml and in login. jsp but of no use. Can anybody please help?? Here are my files::--

struts.xml


index.jsp redirects to login.jsp
web.xml


struts-login.xml


please help.
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are there any messages on startup? Is logging turned up to debug level? Have you checked what Struts 2 thinks your configuration is using the config-browser plugin?
 
Harvinder Singh g
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for replying.

During tomcat startup following is coming:


Iam making a small application just for learning struts2 and i have not done logging yet.
I have checked with config-browser plugin but dont know why it is not showing my namespaces.
 
Harvinder Singh g
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks a lot , it worked after placing struts.xml, struts-login.xml, struts-secure.xml under WEB-INF/classes.
Initially they were in WEB-INF. I had also tried keeping them under src folder but of no use.
Only after placing them under WEB-INF/classes it worked .
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic