• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

Unable to open web service tester page

 
Ranch Hand
Posts: 42
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
When I right click on a web service project and click "Test Web Service". I am getting an "Unable to open webservice tester page
http://localhost:8080/WebServiceApplication2/........

Make sure the service is running properly and server is running"

I checked the server GlassFish is working...what is the problem.
Localhost_notfound2.jpg
[Thumbnail for Localhost_notfound2.jpg]
 
Ranch Hand
Posts: 494
Eclipse IDE Postgres Database Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi..

Before you test the web service, you should deploy it...
if you use netbeans Right click the project, select Run..
and then if the process finish, then you could test the webservice..

Hope that helps..
 
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Leonardo Carreira wrote:Hi..

Before you test the web service, you should deploy it...
if you use netbeans Right click the project, select Run..
and then if the process finish, then you could test the webservice..

Hope that helps..



Hi, I'm experiencing the same problem, I tried your fix, but it didn't work. My GlassFish server's working, and I have deployed the webservice.

I'm using NetBeans 6.8.
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have the same problem???
 
Ranch Hand
Posts: 2198
1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi!
A first test to make sure the web service is correctly deployed is to bring up its WSDL.
If there is no WSDL, then the web service has not been deployed correctly.
This test can be performed from any browser, before using the web service tester.
Best wishes!
 
Ranch Hand
Posts: 367
Eclipse IDE Opera Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Ivan,

Could you please explain how to perform this test.

This test can be performed from any browser, before using the web service tester.



In my case , I get the deployment message in Netbeans output window as follows :
"INFO: CalculatorWSApplication was successfully deployed in 862 milliseconds."

But when I click on http://localhost:8080/CalculatorWS?wsdl ,I get the message "the link appears to be broken."

My code is as follows :

 
Ivan Krizsan
Ranch Hand
Posts: 2198
1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi!
You have already performed the test!
If you do not see the WSDL, despite a deploy that looks successful, I suggest taking a look in the application server logs to make sure that everything indeed is as it should.
Also take a look in the administration console of the application server to see that the web service application appears as it should.
Best wishes!
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
1) Go to http://<hostname>:<port>/ (eg: http://localhost:8080)
You must see 'Your server is now running.

2) Click on 'go to the Administration Console'.

3) On the left navigation click on 'Applications'

4) Select the application and Undeploy.

5) From Netbeans IDE, redeploy the application.

Now you would be able to test the same.
 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I've gone through the steps given by @Ramesh Akella
But still in my NetBeans I'm unable to open the Test page as well as the WSDL page.
I'm using NetBeans 7.3 and GlassFish Server 3.1.2.2
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
It's an old thread, but people keep having the problem and this pops up on the first page of Google search results, So here is the solution that I found.
--

I think the problem is caused by the default setting restricting access to External Schema.

If you are using NetBeans 8.0/7.4/7.3 try the following:

  • Go to the page Getting Started with JAX-WS Web Services
  • Following the Enabling Access to External Schema instruction


  • I think the Glassfish instructions for are the important ones.

    Though, yes, it is a pain that you need to reduce security to get the tester page working.
     
    Ranch Hand
    Posts: 115
    • Mark post as helpful
    • send pies
      Number of slices to send:
      Optional 'thank-you' note:
    • Quote
    • Report post to moderator
    Dears ,

    I still have the same issue.
    The post from @Ramesh Akella copied from stake over flow and it doesn't work.

    Any other suggestion please ?
     
    Ranch Hand
    Posts: 181
    3
    • Mark post as helpful
    • send pies
      Number of slices to send:
      Optional 'thank-you' note:
    • Quote
    • Report post to moderator
    I have same issue with tomcat.
    Does any one know an answer!!!
       
     
    chamini prashakthi
    Ranch Hand
    Posts: 181
    3
    • Mark post as helpful
    • send pies
      Number of slices to send:
      Optional 'thank-you' note:
    • Quote
    • Report post to moderator
    Found the solution
    it was an error of my database.
    Create database again and done everything again.
    It was fixed!!!
     
    Get out of my mind! Look! A tiny ad!
    free, earth-friendly heat - a kickstarter for putting coin in your pocket while saving the earth
    https://coderanch.com/t/751654/free-earth-friendly-heat-kickstarter
    reply
      Bookmark Topic Watch Topic
    • New Topic