• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Paul Clapham
  • Jeanne Boyarsky
  • Knute Snortum
Sheriffs:
  • Liutauras Vilda
  • Tim Cooke
  • Junilu Lacar
Saloon Keepers:
  • Ron McLeod
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Joe Ess
  • salvin francis
  • fred rosenberger

Orion problems

 
buckaroo
Posts: 401
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have downloaded orion2.0.1.zip and extracted all files to C:\orion; copied tools.jar -> C:\orion; from command line @C:\orion>java -jar orion.jar as per instructions for Servlets 1. In all attempts to go to http://localhost give page cannot be found errors. What is really interesting is console displays "orion/1.5.2 initialized" - go figure!
Have I missed a couple steps to my raindance? I have Windows XP Pro Version 2002 Service Pack 1.
TIA
 
hired gun
Posts: 250
MS IE Oracle Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
A couple of things come to mind, first your computer may not know where localhost is, so you can try http://127.0.0.1/ You can also see if your computer has an entry in its "hosts" file located under c:\winnt\system32\drivers\etc\ for localhost or add it yourself, mine looks like this:

Secondly orion may be running on a different port, I don't remember what the default port configuration is so you can look in your orion directory under the config directory for a file called default-web-site.xml It could have a line something like this

<web-site host="[ALL]" port="8080" display-name="Default Orion WebSite">

which means that you will need to point to port 8080 in your browser like this http://localhost:8080/
[ May 26, 2003: Message edited by: John Hembree ]
 
John Hembree
hired gun
Posts: 250
MS IE Oracle Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Originally posted by Donald R. Cossitt:
What is really interesting is console displays "orion/1.5.2 initialized"


You're versioning seems off my console window displays

D:\orion>java -jar orion.jar
Orion/2.0.1 initialized

 
Sheriff
Posts: 9099
12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Originally posted by Donald R. Cossitt:
What is really interesting is console displays "orion/1.5.2 initialized" - go figure!


I think the one I'm currently using is 1.6.0
1.5.2 is really old. Guess I should upgrade. But 1.5.2 worked while I used it.
[ May 26, 2003: Message edited by: Marilyn de Queiroz ]
 
Marilyn de Queiroz
Sheriff
Posts: 9099
12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You could also check C:\orion\config\default-web-site.xml to be sure that you are using port 80
In other words you should see a line that looks something like
<web-site host="[ALL]" port="80" display-name="Default Orion WebSite">

If it says "8080", you need to type
http://localhost:8080/
instead.
 
Donald R. Cossitt
buckaroo
Posts: 401
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator


<web-site host="[ALL]" port="8080" display-name="Default Orion WebSite">


I tried both settings of port="8080" & port="80" to no avail. But I tried again with port="80" and re-booted; it seems to be working fine now - doing the sundance now
Thanks
[ May 26, 2003: Message edited by: Donald R. Cossitt ]
[ May 27, 2003: Message edited by: Marilyn de Queiroz ]
 
Donald R. Cossitt
buckaroo
Posts: 401
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Interesting: I quoted Marilyn and it is not showing up between the QUOTE pairs
 
John Hembree
hired gun
Posts: 250
MS IE Oracle Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
UBB Bug, check it out...
Link
 
Marilyn de Queiroz
Sheriff
Posts: 9099
12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Originally posted by Donald R. Cossitt:
Interesting: I quoted Marilyn and it is not showing up between the QUOTE pairs


Problem due to the < and the > combining with UBB. I fixed it.
 
Evildoers! Eat my justice! And this tiny ad's justice too!
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!