Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

taglib i18n wierd error

 
Jari Timonen
Ranch Hand
Posts: 232
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi.
My tools:
Ecliplse 2.1.2
JBoss-IDE 1.2.2
JBoss 3.2.2
i18n latest build.
I'm having very strange behaviour from i18n. I have login system where
user logs in and goes to main page. When login form is inside JBoss everything works fine. But, if i move my login form to other www-server or I just write index.html and run it on my desktop without any server (sends form to JBoss), i18n brakes down on main page.
It complains fallowing, and if i take client.orderpresents off, it complains next tag.


My configurations:


any ideas???
 
Jari Timonen
Ranch Hand
Posts: 232
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Oh jeah... and i have end of cindex.jsp

this behaviour happengs only if browser != IE
please give me some ideas
 
Jari Timonen
Ranch Hand
Posts: 232
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Problem solved.
I sent the userLocale to Servlet but i forgot to put it to session.
(In Jboss it was set first thing in login.jsp ).
I had default language finnish in IE but English(language file not implemented yet) in Opera and Firefox.
That's why it worked in IE.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic