• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Need Assistance in debugging this

 
Greenhorn
Posts: 17
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
[code] Jan 6, 2010 5:03:57 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Jan 6, 2010 5:03:57 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 1141 ms
Jan 6, 2010 5:03:57 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Jan 6, 2010 5:03:57 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.0.28
Jan 6, 2010 5:03:58 PM org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
Jan 6, 2010 5:03:58 PM org.apache.catalina.loader.WebappClassLoader validateJarFile
INFO: validateJarFile(D:\My Documents\Workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp0\wtpwebapps\AWCMS_S\WEB-INF\lib\javax.servlet-5.1.12.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class
Jan 6, 2010 5:03:58 PM org.apache.catalina.loader.WebappClassLoader validateJarFile
INFO: validateJarFile(D:\My Documents\Workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp0\wtpwebapps\AWCMS_S\WEB-INF\lib\servlet-api-2.4.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class
Jan 6, 2010 5:03:58 PM org.apache.catalina.loader.WebappClassLoader validateJarFile
INFO: validateJarFile(D:\My Documents\Workspace\.metadata\.plugins\org.eclipse.wst.server.core\tmp0\wtpwebapps\AWCMS_S\WEB-INF\lib\servlet-api-2.5-6.0.0beta9.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class
java.io.FileNotFoundException: C:\localhost\AWCMS_S\web-inf\config\xml\ApplicationProperties.xml (The system cannot find the path specified)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:106)
at java.io.FileInputStream.<init>(FileInputStream.java:66)
at sun.net.www.protocol.file.FileURLConnection.connect(FileURLConnection.java:70)
at sun.net.www.protocol.file.FileURLConnection.getInputStream(FileURLConnection.java:161)
at org.apache.xerces.impl.XMLEntityManager.setupCurrentEntity(Unknown Source)
at org.apache.xerces.impl.XMLVersionDetector.determineDocVersion(Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
at org.jdom.input.SAXBuilder.build(SAXBuilder.java:453)
at org.jdom.input.SAXBuilder.build(SAXBuilder.java:891)
at com.oem.awcms.common.configloader.ConfigurationLoader.load(ConfigurationLoader.java:70)
at com.oem.awcms.common.configloader.ConfigurationService.initialize(ConfigurationService.java:83)
at com.oem.awcms.common.configloader.ConfigurationService.loadConfiguration(ConfigurationService.java:43)
at com.oem.awcms.common.configloader.GenericConfigServlet.init(GenericConfigServlet.java:37)
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1029)
at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:862)
at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4013)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4357)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1083)
at org.apache.catalina.core.StandardHost.start(StandardHost.java:789)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1083)
at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:478)
at org.apache.catalina.core.StandardService.start(StandardService.java:480)
at org.apache.catalina.core.StandardServer.start(StandardServer.java:2313)
at org.apache.catalina.startup.Catalina.start(Catalina.java:556)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:592)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:287)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:425)
Jan 6, 2010 5:04:10 PM org.apache.catalina.core.StandardHost getDeployer
INFO: Create Host deployer for direct deployment ( non-jmx )
Jan 6, 2010 5:04:10 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Jan 6, 2010 5:04:10 PM org.apache.jk.common.ChannelSocket init
INFO: JK2: ajp13 listening on /0.0.0.0:8009
Jan 6, 2010 5:04:10 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/31 config=null
Jan 6, 2010 5:04:10 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 12516 ms
[/code]



I have all necessary jars in web-inf/lib folder...but still i am getting this in server's console...i am using tomcat 5...

Thanks in advance.

Regards,
Sakthi.
 
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What is com.oem.awcms.common.configloader.GenericConfigServlet ? Is this your library ? It's trying to read a file at the following location : C:\localhost\AWCMS_S\web-inf\config\xml\ApplicationProperties.xml, and it doesn't find it.
 
Ranch Hand
Posts: 83
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sakthi,

i doubt if this a issue with eclipse plugin , what version of eclipse are you using?


 
Liar, liar, pants on fire! refreshing plug:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic