Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

JBoss 5.1.0GA to Weblogic 8.1 Bridge - Getting CNFE for weblogic.jndi.WLInitialContextFactory

Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I'm attempting to define a JBoss to Weblogic bridge, and having a tough time of it.

I get a CNFE (java.lang.ClassNotFoundException) attempting to load the weblogic.jndi.WLInitialContextFactory class.

My environment is this:

Linux CentOS v5.4
JBoss 5.1.0GA installed from, running a copy of "default" JBoss server configuration.
java version "1.6.0_17"
Weblogic 8.1 SP3 running under Java v1.4 on a different host.

I've tried just deploying my app-bridge-service.xml file with the Weblogic wlclient.jar and wljmsclient.jar in the server/xxx/lib directory.
I've tried packaging my app-bridge-service.xml and the above jars into a .jar file (and removing the wl*.jar files from server/xxx/lib directory) and still get the same issue.
The app-bridge.jar structure looks like this:


Below is the JBoss console output from my app-bridge.jar testcase:

My Weblogic JMS provider is configured as such:

My bridge is configured as such:

I've setup Classloader logging, and below are excerpts (grep WLInitial ucl.log) of what I see (this file is huge, let me know if you need more detail):

What caught my eye in the above was this statement:

[996607,BaseClassLoader,Thread-18] BaseClassLoader@11903ab{vfszip:/home/dh3235/jboss/bridge/deploy/app-bridge.jar/} resource is blacklisted weblogic/jndi/WLInitialContextFactory .class

I haven't been able to figure out how to un-blacklist this and make it work (though I have seen thru the JMX console that I can unblacklist a class, and have tried that, but I still get the CNFE). Not sure if I'm on the right track here or not... If I am, is there any good docs on Classloader blacklisting? My googling hasn't produced anything of value...

So, I'm reaching out for help here.


Dave Hinkle
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Argh, I've figured out why I'm getting the CNFE.

My JMSProvider configuration in wlsjms-ds.xml, which calls out weblogic.jndi.WLInitialContextFactory, had spaces at the end of the line.

What tipped me off were the line like these from the Classloader logging:

The spaces between weblogic/jndi/WLInitialContextFactory and .class was the tip off.

As to the blacklisting, it appears that this happens when the classloader attempts to load the class and gets a CNFE (simplified explanation of it I guess).

So, now off to figure out why I can't get the bridge to work with just wlclient.jar and wljmsclient.jar...

I'll post more as I figure it out.

Consider Paul's rocket mass heater.
    Bookmark Topic Watch Topic
  • New Topic