Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

DynaValidatorForm - very strange problem

 
Artur Wronski
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!
So I've two sites (under different domains). First side has this form-bean:

Second site has form like this:

So both sites have form-beans with the same name but which are different.
When I deploy first site (copy war) it works correct. But when I deploy second site and access the page which use this form a get error like this:

But when I remove first site (delete war file) and deploy second site once again it works correct. Than, when I try to deploy first site again I receive the same error like for the second site for the first time.
So the problem looks like struts mistake this two forms definition?
The problem disappear when the forms have different names but this is not a solution. Those sites are under different domain but run under the same server (Jboss 3.2.3 + Tomcat 5.0.16). I checked this with struts 1.1 and 1.2
Does anyone have any idea what's the problem? I've lost more than 17 hours by now because of this
Please help,
Artur
 
poornima balagopal
Ranch Hand
Posts: 83
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
Can you try this by combining the two form to one i mean create only one form with all these three properties
login
password
code
I think if you try this way it will work. You can use the properties according to the requirement. I mean in one page if you want only login and password that you can give .
I dont have much idea ok? I answered it as the way i felt
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic