Win a copy of Pro Spring MVC with WebFlux: Web Development in Spring Framework 5 and Spring Boot 2 this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Jeanne Boyarsky
  • Liutauras Vilda
Sheriffs:
  • Rob Spoor
  • Bear Bibeault
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Piet Souris
Bartenders:
  • Frits Walraven
  • Himai Minh

Machine name is changed upon joining a network

 
clojure forum advocate
Posts: 3479
Mac Objective C Clojure
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hey,
My machine name is gitano-mac
This name appears when launching the terminal.
gitano-mac:~ john$
But when I'm joining our company WiFi network, the terminal shows my friends's machine name at the terminal !!

my-friend:~ matt$

Not enough? my friend's laptop isn't even connected to the network
Today is the first time this happened.
I'm using DHCP and even when I renew the DHCP, I got the same IP
What is going wrong?

MacBook Pro
SL 10.6.2
Access via airport
FireWall enabled
 
Sheriff
Posts: 13411
Firefox Browser VI Editor Redhat
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I just had the same thing happen (got my first Mac over the weekend).

When I connected the network (with an ethernet cord, no wireless) the machine name took on the name of a consultant's machine who was in the office a couple weeks ago. I'm guessing he was the last person to have that DHCP assigned IP address.

I was able to change it by running the hostname command as root but it reverted to the same thing when I connected this morning.
 
Consider Paul's rocket mass heater.
reply
    Bookmark Topic Watch Topic
  • New Topic